database 0.3.3
database: ^0.3.3 copied to clipboard

A database access API that's vendor-agnostic. Adapters exist for browser APIs, SQLite, Google Cloud Firestore, PostgreSQL, ElasticSearch, Algolia, and others.

80
likes
100 / 130
pub points
82 %
popularity

We analyzed this package on Jun 16, 2021, and awarded it 100 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 441 out of 1118 API elements (39.4 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
built_collection^4.0.04.3.25.1.0
built_value>=5.0.0 <8.0.07.1.08.0.6
charcode^1.1.01.3.11.3.1
collection^1.14.01.15.01.15.0
fixnum^0.10.00.10.111.0.0
meta^1.1.01.4.01.4.0
protobuf>=0.13.0 <2.0.01.1.32.0.0
universal_html^1.1.01.2.42.0.8
universal_io>=0.8.6 <2.0.01.0.22.0.4
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.7.02.7.0
convert-2.1.13.0.0
crypto-2.1.53.0.1
csslib-0.16.20.17.0
html-0.14.0+40.15.0
matcher-0.12.100.12.10
path-1.8.01.8.0
quiver-2.1.53.0.1
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
zone_local-0.1.20.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 6 issues. Showing the first 2:

The constraint `^4.0.0` on built_collection does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions built_collection to update the constraint.

The constraint `>=5.0.0 <8.0.0` on built_value does not support the stable version `8.0.0`.

Try running dart pub upgrade --major-versions built_value to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.6.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.17.1, Dart 2.13.1.

80
likes
100
pub points
82%
popularity

Publisher

dint.dev

A database access API that's vendor-agnostic. Adapters exist for browser APIs, SQLite, Google Cloud Firestore, PostgreSQL, ElasticSearch, Algolia, and others.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache 2.0 (LICENSE)

Dependencies

built_collection, built_value, charcode, collection, fixnum, meta, protobuf, universal_html, universal_io

More

Packages that depend on database