data_review_and_upload 0.0.4
data_review_and_upload: ^0.0.4 copied to clipboard

A new Flutter package Data Review and Upload.

0
likes
25 / 110
pub points
43 %
popularity

We analyzed this package on Apr 13, 2021, and awarded it 25 pub points (of a possible 110):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 image link is insecure.

README.md:4:14

  ╷
4 │ <h2>Demo</h2><img src="http://sheikhsoft.com/screensort/data_review_and_upload.png" width="340" height="640" title="Screen Shoot">
  │              ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 7 out of 56 API elements (12.5 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:data_review_and_upload/data_review_and_upload.dart that imports:
  • package:data_review_and_upload/map_box.dart that imports:
  • package:flutter_map/flutter_map.dart that imports:
  • package:flutter_map/src/layer/tile_layer.dart that imports:
  • package:cached_network_image/cached_network_image.dart that imports:
  • package:cached_network_image/src/cached_network_image_provider.dart that imports:
  • package:flutter_cache_manager/flutter_cache_manager.dart that imports:
  • package:flutter_cache_manager/src/web/web_helper.dart that imports:
  • package:flutter_cache_manager/src/cache_store.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS
Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 11 issues. Showing the first 2:

ERROR: Too many positional arguments: 1 expected, but 2 found.

lib/data_review_and_upload.dart:155:52

    ╷
155 │       Img.Image smallerImg = Img.copyResize(image, 500);
    │                                                    ^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/data_review_and_upload.dart

ERROR: The named parameter 'child' isn't defined.

lib/utils.dart:11:9

   ╷
11 │         child: new CupertinoAlertDialog(
   │         ^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/utils.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
flutter_map^0.5.00.5.60.12.0
http^0.12.0+10.12.20.13.1
image^2.0.72.1.193.0.2
Transitive dependencies
PackageConstraintCompatibleLatest
ansicolor-1.1.12.0.1
archive-2.0.133.1.2
args-1.6.02.0.0
async-2.5.02.5.0
cached_network_image-1.1.33.0.0
characters-1.1.01.1.0
charcode-1.2.01.2.0
clock-1.1.01.1.0
collection-1.15.01.15.0
console_log_handler-1.1.61.1.6
convert-2.1.13.0.0
crypto-2.1.53.0.1
ffi-1.0.01.0.0
file-6.1.06.1.0
flutter_cache_manager-1.4.23.0.1
flutter_image-2.0.13.0.0
http_parser-3.1.44.0.0
intl-0.17.00.17.0
latlong-0.6.10.6.1
logging-0.11.41.0.1
matcher-0.12.100.12.10
meta-1.3.01.3.0
path-1.8.01.8.0
path_provider-1.6.282.0.1
path_provider_linux-0.0.1+22.0.0
path_provider_macos-0.0.4+82.0.0
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.52.0.0
pedantic-1.11.01.11.0
petitparser-3.1.04.1.0
platform-3.0.03.0.0
plugin_platform_interface-1.0.32.0.0
positioned_tap_detector-1.0.31.0.3
process-4.2.14.2.1
quiver-2.1.53.0.1
rxdart-0.24.10.26.0
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
sqflite-1.3.2+42.0.0+3
sqflite_common-1.0.3+32.0.0+2
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
synchronized-2.2.0+23.0.0
term_glyph-1.2.01.2.0
transparent_image-1.0.02.0.0
tuple-1.0.32.0.0
typed_data-1.3.01.3.0
uuid-2.2.23.0.4
validate-1.7.01.7.0
vector_math-2.1.02.1.0
win32-2.0.52.0.5
xdg_directories-0.1.20.2.0
xml-4.5.15.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^0.5.0` on flutter_map does not support the stable version `0.6.0`.

Try running dart pub upgrade --major-versions flutter_map to update the constraint.

The constraint `^0.12.0+1` on http does not support the stable version `0.13.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Flutter 2.0.4, Dart 2.12.2.