dartx 1.2.0 copy "dartx: ^1.2.0" to clipboard
dartx: ^1.2.0 copied to clipboard

Superpowers for Dart. Collection of useful static extension methods.

843
likes
140/ 140
pub points
97%
popularity

We analyzed this package 13 hours ago, and awarded it 140 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

417 out of 685 API elements (60.9 %) have documentation comments.

Some symbols that are missing documentation: dartx.ComparableBetweenExtension, dartx.ComparableBiggerEqualsExtension, dartx.ComparableBiggerEqualsExtension.operator >=, dartx.ComparableBiggerExtension, dartx.ComparableBiggerExtension.operator >.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
characters ^1.1.0 1.3.0 1.3.0
collection ^1.15.0 1.18.0 1.18.0
crypto ^3.0.0 3.0.3 3.0.3
meta ^1.3.0 1.15.0 1.15.0
path ^1.8.0 1.9.0 1.9.0
time ^2.0.0 2.1.4 2.1.4
Transitive dependencies
Package Constraint Compatible Latest
clock - 1.1.1 1.1.1
typed_data - 1.3.2 1.3.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.4.1.

Check the analysis log for details.

843
likes
140
pub points
97%
popularity

Publisher

verified publishersimc.dev

Superpowers for Dart. Collection of useful static extension methods.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

characters, collection, crypto, meta, path, time

More

Packages that depend on dartx