dartpy 0.0.5 copy "dartpy: ^0.0.5" to clipboard
dartpy: ^0.0.5 copied to clipboard

A library for using dart with python via python's C API

42
likes
130/ 160
pub points
76%
popularity

We analyzed this package 35 hours ago, and awarded it 130 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Homepage URL is insecure.

Update the homepage field and use a secure (https) URL.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

39 out of 3171 API elements (1.2 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

To highlight public API members missing documentation consider enabling the public_member_api_docs lint.

Some symbols that are missing documentation: dartpy.ALIGNOF_LONG, dartpy.ALIGNOF_MAX_ALIGN_T, dartpy.ALIGNOF_SIZE_T, dartpy.CO_ASYNC_GENERATOR, dartpy.CO_COROUTINE.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:dartpy/dartpy.dart that imports:
  • package:dartpy/src/dartpy_base.dart that imports:
  • package:dartpy/src/helpers/helpers.dart that imports:
  • package:dartpy/src/helpers/converters/converters.dart that imports:
  • package:dartpy/src/helpers/converters/primitives.dart that imports:
  • package:ffi/ffi.dart that imports:
  • package:ffi/src/utf16.dart that imports:
  • dart:ffi
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 80 issues. Showing the first 2:

INFO: The declaration '_heaptypeobject' isn't referenced.

lib/src/ffi/gen.dart:24177:13

      ╷
24177 │ final class _heaptypeobject extends ffi.Struct {
      │             ^^^^^^^^^^^^^^^
      ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/ffi/gen.dart

INFO: The declaration '_PyCFrame' isn't referenced.

lib/src/ffi/gen.dart:24702:13

      ╷
24702 │ final class _PyCFrame extends ffi.Struct {
      │             ^^^^^^^^^
      ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/ffi/gen.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
args ^2.5.0 2.5.0 2.5.0
ffi ^2.1.2 2.1.2 2.1.2
freezed_annotation ^2.4.1 2.4.1 2.4.1
path ^1.9.0 1.9.0 1.9.0
Transitive dependencies
Package Constraint Compatible Latest
collection - 1.19.0 1.19.0
json_annotation - 4.9.0 4.9.0
meta - 1.15.0 1.15.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Dart 3.4.3.

Check the analysis log for details.

42
likes
130
pub points
76%
popularity

Publisher

verified publishertimwhiting.dev

A library for using dart with python via python's C API

Repository
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

args, ffi, freezed_annotation, path

More

Packages that depend on dartpy