dartman 1.0.1
dartman: ^1.0.1 copied to clipboard

dartman will watch for changes in your projects root directory and restart your app everytime you edit something.

1
likes
70 / 130
pub points
24 %
popularity

We analyzed this package on Apr 29, 2021, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 0 API elements (100.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

INFO: Unnecessary new keyword.

bin/main.dart:6:17

  ╷
6 │ AnsiPen green = new AnsiPen()..green(bold: true);
  │                 ^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer bin/main.dart

INFO: Unnecessary new keyword.

bin/main.dart:7:16

  ╷
7 │ AnsiPen blue = new AnsiPen()..blue();
  │                ^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer bin/main.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
ansicolor^1.0.21.1.12.0.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.2` on ansicolor does not support the stable version `2.0.1`.

Try running dart pub upgrade --major-versions ansicolor to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.2.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Dart 2.12.4.

1
likes
70
pub points
24%
popularity

dartman will watch for changes in your projects root directory and restart your app everytime you edit something.

Homepage

Documentation

API reference

Uploader

loislnessie@gmail.com

License

GPL 3.0 (LICENSE)

Dependencies

ansicolor

More

Packages that depend on dartman