dartjsengine 1.0.1
dartjsengine: ^1.0.1 copied to clipboard

JS engine for Dart.

1
likes
80 / 110
pub points
64 %
popularity

We analyzed this package on Apr 8, 2021, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 13 out of 131 API elements (9.9 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 117 issues. Showing the first 2:

INFO: Prefer using /// for doc comments.

lib/src/JSEngine.dart:6:1

  ╷
6 │ ┌ /**
7 │ │  * JS Engine written in Dart Language.
8 │ └  */
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/JSEngine.dart

INFO: Unnecessary new keyword.

lib/src/JSEngine.dart:14:45

   ╷
14 │   final SymbolTable<JsObject> globalScope = new SymbolTable();
   │                                             ^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/JSEngine.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
jsparser^2.0.12.0.12.0.1
symbol_table^2.0.02.0.02.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
lists-1.0.01.0.0
meta-1.3.01.3.0
unicode-0.3.00.3.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Dart 2.12.2.