dartfx 1.0.14 copy "dartfx: ^1.0.14" to clipboard
dartfx: ^1.0.14 copied to clipboard

A simple lightly function calculator for dart and javascript.

1
likes
110/ 140
pub points
56%
popularity

We analyzed this package 2 days ago, and awarded it 110 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

255 out of 629 API elements (40.5 %) have documentation comments.

Some symbols that are missing documentation: dartfx, dartfx.ADDITIVE_PRECEDENCE, dartfx.ASSIGNMENT_PRECEDENCE, dartfx.Annotation.argumentList, dartfx.Annotation.constructorName.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web

These issues are present but do not affect the score, because they may not originate in your package:

Package not compatible with platform Web

Because:

  • package:dartfx/dartfx.dart that imports:
  • package:dartfx/src/runtime/ast_context.dart that imports:
  • package:dartfx/src/runtime/ast_runtime_executor.dart that imports:
  • package:dartfx/src/runtime/ast_runtime_node.dart that imports:
  • package:dartfx/src/util/logger.dart that imports:
  • package:logger/logger.dart that imports:
  • package:logger/src/outputs/file_output_stub.dart that imports:
  • dart:io
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 207 issues. Showing the first 2:

WARNING: The getter doesn't override an inherited getter.

lib/src/ast/element.dart:591:12

    ╷
591 │   bool get isStatic;
    │            ^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/ast/element.dart

WARNING: Unused import: 'package:analyzer/dart/element/type_provider.dart'.

lib/src/ast/results.dart:11:8

   ╷
11 │ import 'package:analyzer/dart/element/type_provider.dart';
   │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/ast/results.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
analyzer ^5.2.0 5.13.0 6.4.1
convert ^3.1.1 3.1.1 3.1.1
crypto ^3.0.2 3.0.3 3.0.3
intl any 0.19.0 0.19.0
logger ^1.1.0 1.4.0 2.0.2+1
meta ^1.8.0 1.12.0 1.12.0
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 61.0.0 67.0.0
async - 2.11.0 2.11.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
file - 7.0.0 7.0.0
glob - 2.1.2 2.1.2
package_config - 2.1.0 2.1.0
path - 1.9.0 1.9.0
pub_semver - 2.1.4 2.1.4
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
watcher - 1.1.0 1.1.0
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^5.2.0` on analyzer does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

The constraint `^1.1.0` on logger does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions logger to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.0, Dart 3.3.0.

Check the analysis log for details.

1
likes
110
pub points
56%
popularity

Publisher

verified publisherdev.apptoy.cc

A simple lightly function calculator for dart and javascript.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

analyzer, convert, crypto, intl, logger, meta

More

Packages that depend on dartfx