dartfix 0.1.7

Dart native
Flutter Android iOS

A tool for migrating Dart source to newer versions of the Dart SDK and fixing common issues.

5
likes
90 / 110
pub points
51 %
popularity

We analyzed this package on Oct 27, 2020, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 20 out of 31 API elements (64.5 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:dartfix/listener/recording_listener.dart that imports:
  • package:analysis_server_client/server.dart that imports:
  • package:analysis_server_client/src/server_base.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analysis_server_client>=1.1.3 <1.1.41.1.31.1.3
args^1.4.01.6.01.6.0
cli_util^0.1.30.1.40.2.0
path^1.7.01.7.01.7.0
pub_semver^1.4.41.4.41.4.4
Transitive dependencies
PackageConstraintCompatibleLatest
collection-1.14.131.14.13

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.1.3` on cli_util does not support the latest published version `0.2.0`

pubspec.yaml:19:13

   ╷
19 │   cli_util: ^0.1.3
   │             ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs