dartf 0.3.0 copy "dartf: ^0.3.0" to clipboard
dartf: ^0.3.0 copied to clipboard

Superpowers for Dart. A collection of useful static extension methods.

10
likes
120/ 140
pub points
39%
popularity

We analyzed this package 3 days ago, and awarded it 120 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

419 out of 689 API elements (60.8 %) have documentation comments.

Some symbols that are missing documentation: dartf.ComparableBetweenExtension, dartf.ComparableBiggerEqualsExtension, dartf.ComparableBiggerEqualsExtension.operator >=, dartf.ComparableBiggerExtension, dartf.ComparableBiggerExtension.operator >.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 17 issues. Showing the first 2:

INFO: The part-of directive uses a library name.

lib/src/arithmetic.dart:1:1

  ╷
1 │ part of dartf;
  │ ^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/arithmetic.dart

INFO: The part-of directive uses a library name.

lib/src/comparable.dart:1:1

  ╷
1 │ part of dartf;
  │ ^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/comparable.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
async ^2.11.0 2.11.0 2.11.0
characters ^1.1.0 1.3.0 1.3.0
collection ^1.15.0 1.18.0 1.18.0
crypto ^3.0.0 3.0.3 3.0.3
meta ^1.3.0 1.12.0 1.12.0
path ^1.8.0 1.9.0 1.9.0
time ^2.0.0 2.1.4 2.1.4
Transitive dependencies
Package Constraint Compatible Latest
clock - 1.1.1 1.1.1
typed_data - 1.3.2 1.3.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.1, Dart 3.3.0.

Check the analysis log for details.

10
likes
120
pub points
39%
popularity

Publisher

verified publisheralexrintt.io

Superpowers for Dart. A collection of useful static extension methods.

Repository (GitHub)
View/report issues

Documentation

API reference

License

unknown (LICENSE)

Dependencies

async, characters, collection, crypto, meta, path, time

More

Packages that depend on dartf