dartboot_util 1.0.0
dartboot_util: ^1.0.0 copied to clipboard

The util library for DartBoot framework.

0
likes
70 / 130
pub points
38 %
popularity

We analyzed this package on May 12, 2021, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/dartboot_util_example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 30 out of 45 API elements (66.7 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:dartboot_util/dartboot_util.dart that imports:
  • package:dartboot_util/src/pageable.dart that imports:
  • package:dartboot_util/src/json.dart that imports:
  • dart:mirrors
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: Use isEmpty instead of length

lib/src/pageable.dart:31:21

   ╷
31 │   bool get empty => (content ?? []).length == 0;
   │                     ^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/pageable.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
uuid^2.2.22.2.23.0.4
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.2.01.2.0
collection-1.15.01.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.1
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.2.2` on uuid does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions uuid to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.10.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Dart 2.12.4.

0
likes
70
pub points
38%
popularity

The util library for DartBoot framework.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

luodongseu@gmail.com

License

MIT (LICENSE)

Dependencies

uuid

More

Packages that depend on dartboot_util