dart_where39 1.0.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 50

Where93 - Dart Version #

This is the Dart version for the original where39 library for the web: Where39

Example #

See the example folder for a more in depth example.

final LatLng latLng = LatLng(52.49303704, 13.41792593);

    // create a Where39 instance without shuffle
    final Where39 w39 = Where39();

    // convert the coordinates to words
    List<String> words = w39.toWords(latLng);
    print(words);
    // prints: [slush extend until layer arch]

    LatLng coords = w39.fromWords([
      'slush',
      'extend',
      'until',
      'layer',
      'arch',
    ]);
    print(coords);
    // prints: LatLng(latitude:52.493037, longitude:13.417926)

    // shuffle the seed
    w39.shuffle = 1337;
    words = w39.toWords(latLng);
    print(words);
    // prints: [small, extra, unusual, lazy, accident]

Issues #

File any issues to the github issue tracker

License #

See LICENSE file

[1.0.0] - 2019-11-17

  • Initial release

example/README.md

Where 39 #

A simple mapping application that uses words to instead of latitude and longitudes.

Original: https://where39.com / source

Building #

You can follow these instructions to build the app and install it onto your device.

Prerequisites #

If you are new to Flutter, please first follow the Flutter Setup guide.

Building and installing the Flutter app #

  • cd example
  • flutter pub get
  • flutter run --release

The flutter run --release command both builds and installs the app.

Screenshots #

Unshuffled seed Shuffled seed Shuffling Word entry

Icon #

Android launcher icons were generated using Android Asset Studio: https://romannurik.github.io/AndroidAssetStudio/icons-launcher.html

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  dart_where39: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:dart_where39/where39.dart';
import 'package:dart_where39/word_list.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
50
Learn more about scoring.

We analyzed this package on Jan 19, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4

Health issues and suggestions

Document public APIs. (-1 points)

9 out of 9 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/where39.dart. (-0.50 points)

Analysis of lib/where39.dart reported 1 hint:

line 55 col 9: Use isEmpty instead of length

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.2.2 <3.0.0
latlong ^0.6.1 0.6.1
Transitive dependencies
ansicolor 1.0.2
console_log_handler 1.1.6
intl 0.16.1
logging 0.11.4
path 1.6.4
validate 1.7.0
Dev dependencies
test ^1.0.0