dart_unitz 0.0.5 copy "dart_unitz: ^0.0.5" to clipboard
dart_unitz: ^0.0.5 copied to clipboard

A simple and expandable unit conversion library. Quickly and easily convert between units and apply math operations on any unit.

1
likes
150/ 160
pub points
0%
popularity

We analyzed this package 41 hours ago, and awarded it 150 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

358 out of 415 API elements (86.3 %) have documentation comments.

Some symbols that are missing documentation: dart_unitz, dart_unitz.Atto, dart_unitz.Atto.Atto, dart_unitz.Exa, dart_unitz.Exa.Exa.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 57 issues. Showing the first 2:

INFO: The part-of directive uses a library name.

lib/src/angle/angle.dart:1:1

  ╷
1 │ part of dart_unitz;
  │ ^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/angle/angle.dart

INFO: The part-of directive uses a library name.

lib/src/angle/arcminute.dart:1:1

  ╷
1 │ part of dart_unitz;
  │ ^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/angle/arcminute.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
meta ^1.9.1 1.15.0 1.15.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.7, Dart 3.4.3.

Check the analysis log for details.

1
likes
150
pub points
0%
popularity

Publisher

verified publishermj12358.dev

A simple and expandable unit conversion library. Quickly and easily convert between units and apply math operations on any unit.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

meta

More

Packages that depend on dart_unitz