dart_square 0.1.0

  • Readme
  • Changelog
  • Installing
  • 32

dart_square2

1.0.0 #

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  dart_square: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:dart_square/dart_square.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
86
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
30
Overall:
Weighted score of the above. [more]
32
Learn more about scoring.

We analyzed this package on Nov 15, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.0
  • pana: 0.12.21

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:dart_square/dart_square.dart.

Health issues and suggestions

Document public APIs. (-0.96 points)

760 out of 761 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/src/catalog/catalog.api.dart. (-6.31 points)

Analysis of lib/src/catalog/catalog.api.dart reported 13 hints, including:

line 21 col 9: Don't explicitly initialize variables to null.

line 42 col 9: Don't explicitly initialize variables to null.

line 63 col 9: Don't explicitly initialize variables to null.

line 83 col 9: Don't explicitly initialize variables to null.

line 107 col 9: Don't explicitly initialize variables to null.

Fix lib/src/transactions/transactions.api.dart. (-3.45 points)

Analysis of lib/src/transactions/transactions.api.dart reported 7 hints, including:

line 26 col 9: Don't explicitly initialize variables to null.

line 48 col 9: Don't explicitly initialize variables to null.

line 70 col 9: Don't explicitly initialize variables to null.

line 95 col 9: Don't explicitly initialize variables to null.

line 120 col 9: Don't explicitly initialize variables to null.

Fix lib/src/orders/orders.api.dart. (-1 points)

Analysis of lib/src/orders/orders.api.dart reported 2 hints:

line 22 col 9: Don't explicitly initialize variables to null.

line 43 col 9: Don't explicitly initialize variables to null.

Fix additional 85 files with analysis or formatting issues. (-3 points)

Additional issues in the following files:

  • lib/src/reporting/reporting.api.dart (2 hints)
  • lib/src/applepay/applepay.api.dart (1 hint)
  • lib/src/auth/auth.api.dart (1 hint)
  • lib/src/checkout/checkout.api.dart (1 hint)
  • lib/src/locations/locations.api.dart (1 hint)
  • lib/dart_square.dart (Run dartfmt to format lib/dart_square.dart.)
  • lib/shared.dart (Run dartfmt to format lib/shared.dart.)
  • lib/src/applepay/applepay.dart (Run dartfmt to format lib/src/applepay/applepay.dart.)
  • lib/src/applepay/requests/register.dart (Run dartfmt to format lib/src/applepay/requests/register.dart.)
  • lib/src/applepay/requests/requests.dart (Run dartfmt to format lib/src/applepay/requests/requests.dart.)
  • lib/src/applepay/responses/register.dart (Run dartfmt to format lib/src/applepay/responses/register.dart.)
  • lib/src/applepay/responses/responses.dart (Run dartfmt to format lib/src/applepay/responses/responses.dart.)
  • lib/src/auth/auth.dart (Run dartfmt to format lib/src/auth/auth.dart.)
  • lib/src/auth/requests/authorization.dart (Run dartfmt to format lib/src/auth/requests/authorization.dart.)
  • lib/src/auth/requests/requests.dart (Run dartfmt to format lib/src/auth/requests/requests.dart.)
  • lib/src/auth/responses/authorization.dart (Run dartfmt to format lib/src/auth/responses/authorization.dart.)
  • lib/src/auth/responses/responses.dart (Run dartfmt to format lib/src/auth/responses/responses.dart.)
  • lib/src/catalog/catalog.dart (Run dartfmt to format lib/src/catalog/catalog.dart.)
  • lib/src/catalog/models/category.dart (Run dartfmt to format lib/src/catalog/models/category.dart.)
  • lib/src/catalog/models/discount.dart (Run dartfmt to format lib/src/catalog/models/discount.dart.)
  • lib/src/catalog/models/idmapping.dart (Run dartfmt to format lib/src/catalog/models/idmapping.dart.)
  • lib/src/catalog/models/inforesponselimits.dart (Run dartfmt to format lib/src/catalog/models/inforesponselimits.dart.)
  • lib/src/catalog/models/item.dart (Run dartfmt to format lib/src/catalog/models/item.dart.)
  • lib/src/catalog/models/itemvariation.dart (Run dartfmt to format lib/src/catalog/models/itemvariation.dart.)
  • lib/src/catalog/models/models.dart (Run dartfmt to format lib/src/catalog/models/models.dart.)
  • lib/src/catalog/models/modifier.dart (Run dartfmt to format lib/src/catalog/models/modifier.dart.)
  • lib/src/catalog/models/modifierlist.dart (Run dartfmt to format lib/src/catalog/models/modifierlist.dart.)
  • lib/src/catalog/models/object.dart (Run dartfmt to format lib/src/catalog/models/object.dart.)
  • lib/src/catalog/models/objectbatch.dart (Run dartfmt to format lib/src/catalog/models/objectbatch.dart.)
  • lib/src/catalog/models/query.dart (Run dartfmt to format lib/src/catalog/models/query.dart.)
  • lib/src/catalog/models/tax.dart (Run dartfmt to format lib/src/catalog/models/tax.dart.)
  • lib/src/catalog/requests/batchdelete.dart (Run dartfmt to format lib/src/catalog/requests/batchdelete.dart.)
  • lib/src/catalog/requests/batchretrieve.dart (Run dartfmt to format lib/src/catalog/requests/batchretrieve.dart.)
  • lib/src/catalog/requests/batchupsert.dart (Run dartfmt to format lib/src/catalog/requests/batchupsert.dart.)
  • lib/src/catalog/requests/requests.dart (Run dartfmt to format lib/src/catalog/requests/requests.dart.)
  • lib/src/catalog/requests/search.dart (Run dartfmt to format lib/src/catalog/requests/search.dart.)
  • lib/src/catalog/requests/updatemodifiers.dart (Run dartfmt to format lib/src/catalog/requests/updatemodifiers.dart.)
  • lib/src/catalog/requests/updatetaxes.dart (Run dartfmt to format lib/src/catalog/requests/updatetaxes.dart.)
  • lib/src/catalog/requests/upsert.dart (Run dartfmt to format lib/src/catalog/requests/upsert.dart.)
  • lib/src/catalog/responses/batchdelete.dart (Run dartfmt to format lib/src/catalog/responses/batchdelete.dart.)
  • lib/src/catalog/responses/batchretrieve.dart (Run dartfmt to format lib/src/catalog/responses/batchretrieve.dart.)
  • lib/src/catalog/responses/batchupsert.dart (Run dartfmt to format lib/src/catalog/responses/batchupsert.dart.)
  • lib/src/catalog/responses/cataloginfo.dart (Run dartfmt to format lib/src/catalog/responses/cataloginfo.dart.)
  • lib/src/catalog/responses/delete.dart (Run dartfmt to format lib/src/catalog/responses/delete.dart.)
  • lib/src/catalog/responses/list.dart (Run dartfmt to format lib/src/catalog/responses/list.dart.)
  • lib/src/catalog/responses/responses.dart (Run dartfmt to format lib/src/catalog/responses/responses.dart.)
  • lib/src/catalog/responses/retrieve.dart (Run dartfmt to format lib/src/catalog/responses/retrieve.dart.)
  • lib/src/catalog/responses/search.dart (Run dartfmt to format lib/src/catalog/responses/search.dart.)
  • lib/src/catalog/responses/updateitem.dart (Run dartfmt to format lib/src/catalog/responses/updateitem.dart.)
  • lib/src/catalog/responses/upsert.dart (Run dartfmt to format lib/src/catalog/responses/upsert.dart.)
  • lib/src/checkout/checkout.dart (Run dartfmt to format lib/src/checkout/checkout.dart.)
  • lib/src/checkout/requests/create.dart (Run dartfmt to format lib/src/checkout/requests/create.dart.)
  • lib/src/checkout/requests/requests.dart (Run dartfmt to format lib/src/checkout/requests/requests.dart.)
  • lib/src/checkout/responses/create.dart (Run dartfmt to format lib/src/checkout/responses/create.dart.)
  • lib/src/checkout/responses/responses.dart (Run dartfmt to format lib/src/checkout/responses/responses.dart.)
  • lib/src/locations/locations.dart (Run dartfmt to format lib/src/locations/locations.dart.)
  • lib/src/locations/responses/list.dart (Run dartfmt to format lib/src/locations/responses/list.dart.)
  • lib/src/locations/responses/responses.dart (Run dartfmt to format lib/src/locations/responses/responses.dart.)
  • lib/src/orders/orders.dart (Run dartfmt to format lib/src/orders/orders.dart.)
  • lib/src/orders/requests/create.dart (Run dartfmt to format lib/src/orders/requests/create.dart.)
  • lib/src/orders/requests/requests.dart (Run dartfmt to format lib/src/orders/requests/requests.dart.)
  • lib/src/orders/requests/retrieve.dart (Run dartfmt to format lib/src/orders/requests/retrieve.dart.)
  • lib/src/orders/responses/create.dart (Run dartfmt to format lib/src/orders/responses/create.dart.)
  • lib/src/orders/responses/responses.dart (Run dartfmt to format lib/src/orders/responses/responses.dart.)
  • lib/src/orders/responses/retrieve.dart (Run dartfmt to format lib/src/orders/responses/retrieve.dart.)
  • lib/src/reporting/reporting.dart (Run dartfmt to format lib/src/reporting/reporting.dart.)
  • lib/src/reporting/responses/additional_receivables.dart (Run dartfmt to format lib/src/reporting/responses/additional_receivables.dart.)
  • lib/src/reporting/responses/additional_refunds.dart (Run dartfmt to format lib/src/reporting/responses/additional_refunds.dart.)
  • lib/src/reporting/responses/responses.dart (Run dartfmt to format lib/src/reporting/responses/responses.dart.)
  • lib/src/shared/additionalrecipient.dart (Run dartfmt to format lib/src/shared/additionalrecipient.dart.)
  • lib/src/shared/address.dart (Run dartfmt to format lib/src/shared/address.dart.)
  • lib/src/shared/card.dart (Run dartfmt to format lib/src/shared/card.dart.)
  • lib/src/shared/money.dart (Run dartfmt to format lib/src/shared/money.dart.)
  • lib/src/shared/order.dart (Run dartfmt to format lib/src/shared/order.dart.)
  • lib/src/shared/squareerror.dart (Run dartfmt to format lib/src/shared/squareerror.dart.)
  • lib/src/shared/transaction.dart (Run dartfmt to format lib/src/shared/transaction.dart.)
  • lib/src/transactions/requests/charge.dart (Run dartfmt to format lib/src/transactions/requests/charge.dart.)
  • lib/src/transactions/requests/refund.dart (Run dartfmt to format lib/src/transactions/requests/refund.dart.)
  • lib/src/transactions/requests/requests.dart (Run dartfmt to format lib/src/transactions/requests/requests.dart.)
  • lib/src/transactions/responses/capture.dart (Run dartfmt to format lib/src/transactions/responses/capture.dart.)
  • lib/src/transactions/responses/charge.dart (Run dartfmt to format lib/src/transactions/responses/charge.dart.)
  • lib/src/transactions/responses/refund.dart (Run dartfmt to format lib/src/transactions/responses/refund.dart.)
  • lib/src/transactions/responses/responses.dart (Run dartfmt to format lib/src/transactions/responses/responses.dart.)
  • lib/src/transactions/responses/transaction.dart (Run dartfmt to format lib/src/transactions/responses/transaction.dart.)
  • lib/src/transactions/transactions.dart (Run dartfmt to format lib/src/transactions/transactions.dart.)

Maintenance issues and suggestions

Support latest dependencies. (-20 points)

The version constraint in pubspec.yaml does not support the latest published versions for 2 dependencies (json_annotation, reflutter).

Homepage URL doesn't exist. (-20 points)

At the time of the analysis the homepage field https://www.github.com/ctartamella/dart_square was unreachable.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and dart_square.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is getting outdated.

The package was last published 52 weeks ago.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
http ^0.12.0 0.12.0+2
json_annotation ^2.0.0 2.4.0 3.0.0
reflutter ^0.4.5 0.4.5 0.6.0
Transitive dependencies
analyzer 0.32.6 0.39.1
args 1.5.2
async 2.4.0
charcode 1.1.2
collection 1.14.12
convert 2.1.1
crypto 2.1.3
csslib 0.16.1
front_end 0.1.4+2 0.1.29
glob 1.2.0
html 0.14.0+3
http_parser 3.1.3
js 0.6.1+1
kernel 0.3.4+2 0.3.29
logging 0.11.3+2
meta 1.1.8
node_interop 1.0.3
node_io 1.0.1+2
package_config 1.1.0
path 1.6.4
pedantic 1.8.0+1
plugin 0.2.0+3
source_span 1.5.5
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
watcher 0.9.7+12
yaml 2.2.0
Dev dependencies
build_runner ^1.1.1
json_serializable ^2.0.0
reflutter_generator ^0.4.5