reflutter 0.6.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 50

../README.md

../CHANGELOG.md

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  reflutter: ^0.6.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:reflutter/reflutter.dart';
  
Version Uploaded Documentation Archive
0.6.0 Mar 12, 2019 Go to the documentation of reflutter 0.6.0 Download reflutter 0.6.0 archive
0.5.2 Dec 3, 2018 Go to the documentation of reflutter 0.5.2 Download reflutter 0.5.2 archive
0.5.1 Nov 26, 2018 Go to the documentation of reflutter 0.5.1 Download reflutter 0.5.1 archive
0.5.0 Nov 25, 2018 Go to the documentation of reflutter 0.5.0 Download reflutter 0.5.0 archive
0.4.5 Nov 13, 2018 Go to the documentation of reflutter 0.4.5 Download reflutter 0.4.5 archive
0.4.1 Nov 7, 2018 Go to the documentation of reflutter 0.4.1 Download reflutter 0.4.1 archive
0.4.0 Oct 25, 2018 Go to the documentation of reflutter 0.4.0 Download reflutter 0.4.0 archive
0.3.0+1 Jul 8, 2018 Go to the documentation of reflutter 0.3.0+1 Download reflutter 0.3.0+1 archive
0.3.0 Jul 8, 2018 Go to the documentation of reflutter 0.3.0 Download reflutter 0.3.0 archive
0.2.4 Jun 23, 2018 Go to the documentation of reflutter 0.2.4 Download reflutter 0.2.4 archive

All 21 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
12
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
50
Learn more about scoring.

We analyzed this package on Jun 20, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.2
  • pana: 0.12.18

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:reflutter/reflutter.dart.

Health suggestions

Fix lib/src/reflutter.dart. (-0.50 points)

Analysis of lib/src/reflutter.dart reported 1 hint:

line 18 col 7: DO use curly braces for all flow control structures.

Maintenance issues and suggestions

Support latest dependencies. (-20 points)

The version constraint in pubspec.yaml does not support the latest published versions for 3 dependencies (1 direct: analyzer).

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and reflutter.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.63.0 <3.0.0
analyzer ^0.32.1 0.32.6 0.36.3
http ^0.12.0 0.12.0+2
meta ^1.1.5 1.1.7
Transitive dependencies
args 1.5.2
async 2.2.0
charcode 1.1.2
collection 1.14.11
convert 2.1.1
crypto 2.0.6
csslib 0.16.0
front_end 0.1.4+2 0.1.18
glob 1.1.7
html 0.14.0+2
http_parser 3.1.3
kernel 0.3.4+2 0.3.18
logging 0.11.3+2
package_config 1.0.5
path 1.6.2
pedantic 1.7.0
plugin 0.2.0+3
source_span 1.5.5
string_scanner 1.0.4
term_glyph 1.1.0
typed_data 1.1.6
watcher 0.9.7+10
yaml 2.1.16
Dev dependencies
test any