dart_pubspec_licenses 3.0.1 copy "dart_pubspec_licenses: ^3.0.1" to clipboard
dart_pubspec_licenses: ^3.0.1 copied to clipboard

A library to make it easy to extract OSS license information from Dart packages using pubspec.yaml

1
likes
110/ 140
pub points
63%
popularity

We analyzed this package 6 days ago, and awarded it 110 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

1 out of 32 API elements (3.1 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: dart_pubspec_licenses, dart_pubspec_licenses.AllProjectDependencies, dart_pubspec_licenses.AllProjectDependencies.AllProjectDependencies, dart_pubspec_licenses.AllProjectDependencies.devDependencies, dart_pubspec_licenses.Package.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:dart_pubspec_licenses/dart_pubspec_licenses.dart that imports:
  • package:dart_pubspec_licenses/src/package.dart that imports:
  • dart:io
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

lib/src/license_info_utils.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/src/package.dart doesn't match the Dart formatter.

To format your files run: dart format .

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
json_annotation ^4.8.1 4.9.0 4.9.0
path ^1.9.0 1.9.0 1.9.0
yaml ^3.1.2 3.1.2 3.1.2
Transitive dependencies
Package Constraint Compatible Latest
collection - 1.18.0 1.18.0
meta - 1.15.0 1.15.0
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.4.0.

Check the analysis log for details.

1
likes
110
pub points
63%
popularity

Publisher

verified publisherespresso3389.jp

A library to make it easy to extract OSS license information from Dart packages using pubspec.yaml

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

json_annotation, path, yaml

More

Packages that depend on dart_pubspec_licenses