dart_predict 1.0.2 copy "dart_predict: ^1.0.2" to clipboard
dart_predict: ^1.0.2 copied to clipboard

Dart port of js predict library https://github.com/jbpringuey/predict

1
likes
120/ 160
pub points
45%
popularity

We analyzed this package 4 days ago, and awarded it 120 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

0 out of 18 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

To highlight public API members missing documentation consider enabling the public_member_api_docs lint.

Some symbols that are missing documentation: dart_predict, dart_predict.astro_unit, dart_predict.defaultMinElevation, dart_predict.deg2rad, dart_predict.max_iterations.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 12 issues. Showing the first 2:

WARNING: The operand can't be null, so the condition is always 'true'.

lib/dart_predict.dart:121:11

    ╷
121 │   if (qth != null && !_aosHappens(satrec, qth)) {
    │           ^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/dart_predict.dart

WARNING: The value of the local variable 'time' isn't used.

lib/dart_predict.dart:417:7

    ╷
417 │   var time = start.millisecondsSinceEpoch;
    │       ^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/dart_predict.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
satellite_dart ^1.0.2 1.0.2 1.0.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Dart 3.4.4.

Check the analysis log for details.

1
likes
120
pub points
45%
popularity

Publisher

unverified uploader

Dart port of js predict library https://github.com/jbpringuey/predict

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (license)

Dependencies

satellite_dart

More

Packages that depend on dart_predict