dart_native 0.7.11 icon indicating copy to clipboard operation
dart_native: ^0.7.11 copied to clipboard

Write native code using Dart. This package liberates you from native code and low performance channel.

20
likes
115/ 140
pub points
67%
popularity

We analyzed this package 4 hours ago, and awarded it 115 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
25 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 9 links are insecure.

README.md:252:5

    ╷
252 │ <li><a href="http://yulingtianxia.com/blog/2020/06/25/Codegen-for-DartNative/">告别 Flutter Channel,调用 Native API 仅需一行代码!</a></li>
    │     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 271 out of 835 API elements (32.5 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ MacOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:dart_native/dart_native.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `Linux`.

Because:

  • package:dart_native/dart_native.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `Web`.

Because:

  • package:dart_native/dart_native.dart that declares support for platforms: Android, iOS, macOS.
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 7 issues. Showing the first 2:

INFO: Avoid using unnecessary statements.

lib/src/darwin/foundation/internal/native_struct.dart:78:5

   ╷
78 │     wrapper;
   │     ^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/darwin/foundation/internal/native_struct.dart

INFO: Avoid using unnecessary statements.

lib/src/darwin/foundation/internal/native_struct.dart:155:5

    ╷
155 │     wrapper;
    │     ^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/darwin/foundation/internal/native_struct.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
dart_native_gen^0.3.30.3.30.4.0
ffi>=1.1.2 <3.0.02.0.12.0.1
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-52.0.052.0.0
analyzer-5.4.05.4.0
args-2.3.22.3.2
async-2.10.02.10.0
build-2.3.12.3.1
characters-1.2.11.2.1
collection-1.17.01.17.1
convert-3.1.13.1.1
crypto-3.0.23.0.2
dart_style-2.2.42.2.4
file-6.1.46.1.4
glob-2.1.12.1.1
js-0.6.50.6.7
logging-1.1.11.1.1
material_color_utilities-0.2.00.2.0
meta-1.8.01.9.0
package_config-2.1.02.1.0
path-1.8.31.8.3
pub_semver-2.1.32.1.3
sky_engine-0.0.990.0.99
source_gen-1.2.71.2.7
source_span-1.9.11.9.1
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
vector_math-2.1.42.1.4
watcher-1.0.21.0.2
yaml-3.1.13.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.3.3` on dart_native_gen does not support the stable version `0.4.0`.

Try running dart pub upgrade --major-versions dart_native_gen to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.25, Flutter 3.7.0, Dart 2.19.0.

20
likes
115
pub points
67%
popularity

Publisher

unverified uploader

Write native code using Dart. This package liberates you from native code and low performance channel.

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.BSD-3-Clause (LICENSE)

Dependencies

dart_native_gen, ffi, flutter

More

Packages that depend on dart_native