dart_lcg 0.1.2
dart_lcg: ^0.1.2 copied to clipboard

Simple dart Project to Illustrate how to publish a dart package.

0
likes
60 / 110
pub points
8 %
popularity

We analyzed this package on Feb 26, 2021, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

No `README.md` found.

The README.md file should inform others about your project, what it does, and how they can use it. See: the example generated by stagehand.

0/5 points: Provide a valid CHANGELOG.md

No `CHANGELOG.md` found.

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 28 API elements (3.6 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

ERROR: 'LCG.==' ('bool Function(LCG)') isn't a valid override of 'Object.==' ('bool Function(Object)').

lib/lcg/lcg.dart:58:16

   ╷
58 │   bool operator==(LCG other) {
   │                ^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/lcg/lcg.dart

INFO: Avoid return types on setters.

lib/lcg/lcg.dart:19:3

   ╷
19 │   void set seed(int newSeed) {seedValue = newSeed;}
   │   ^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/lcg/lcg.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

No dependencies.

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.14.10, Dart 2.10.5.

0
likes
60
pub points
8%
popularity

Publisher

gfleet.games

Simple dart Project to Illustrate how to publish a dart package.

Homepage

Documentation

API reference

License

MIT (LICENSE)

More

Packages that depend on dart_lcg