dart_json_mapper_mobx 1.2.2

Dart native js
Flutter Android iOS web

This is a dart-json-mapper complementary package provides support for MobX Stores to persist as JSON.

1.2.2 #

  • Support for new code generation contract

1.2.1 #

  • Converter for ObservableMap<K,V> w/o decorators, when Map is pre-initialized

1.2.0 #

  • Support for Observable iterables, w/o decorators

1.1.0 #

  • Support for new adapters contract
  • mobx version bump

1.0.1 #

  • mobx version bump

1.0.0 #

  • pedantic linter adopted

0.1.0 #

  • Added support for Observable, ObservableList, ObservableSet, ObservableMap

0.0.1 #

  • Added support for ObservableList<T>, where T in
[String, bool, num, int, double, DateTime]
5
likes
100
pub points
78%
popularity

Publisher

edensapple.com

This is a dart-json-mapper complementary package provides support for MobX Stores to persist as JSON.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

dart_json_mapper, mobx

More

Packages that depend on dart_json_mapper_mobx