dart_interval 0.1.3 icon indicating copy to clipboard operation
dart_interval: ^0.1.3 copied to clipboard

This library provides data structure and operations for intervals in Dart.

2
likes
120/ 140
pub points
28%
popularity

We analyzed this package 30 hours ago, and awarded it 120 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 28 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

INFO: Unused import: 'dart:math'.

lib/dart_interval.dart:1:8

  ╷
1 │ import 'dart:math';
  │        ^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/dart_interval.dart

INFO: The variable name 'comes_before' isn't a lowerCamelCase identifier.

lib/dart_interval.dart:23:8

   ╷
23 │   bool comes_before(Interval other) {
   │        ^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/dart_interval.dart

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

No dependencies.

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.25, Dart 2.19.0.

2
likes
120
pub points
28%
popularity

Publisher

verified publisher iconfxcdev.com

This library provides data structure and operations for intervals in Dart.

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.BSD-3-Clause (LICENSE)

More

Packages that depend on dart_interval