dart_firebase 0.0.1+1

Firebase for Dart Build Status

Wrapper for the Firebase REST API in Pure Dart for Web and Desktop or Mobile.

05.14.2019 #

  • Base Wrapper Added

example/README.md

example #

A new Flutter project.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  dart_firebase: ^0.0.1+1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:dart_firebase/api.dart';
import 'package:dart_firebase/tool.dart';
import 'package:dart_firebase/utils/push_id_generator.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
38
Health:
Code health derived from static analysis. [more]
96
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
71
Overall:
Weighted score of the above. [more]
62
Learn more about scoring.

We analyzed this package on Aug 14, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19

Platforms

Detected platforms: Flutter, other

Platform components identified in package: io.

Health suggestions

Fix lib/src/impl/common/http.dart. (-2.96 points)

Analysis of lib/src/impl/common/http.dart reported 6 hints, including:

line 7 col 14: The top level variable '_defaultAppName' isn't used.

line 101 col 21: Use = to separate a named parameter from its default value.

line 102 col 20: Use = to separate a named parameter from its default value.

line 109 col 21: Use = to separate a named parameter from its default value.

line 110 col 20: Use = to separate a named parameter from its default value.

Fix lib/src/impl/browser.dart. (-0.50 points)

Analysis of lib/src/impl/browser.dart reported 1 hint:

line 19 col 23: Use = to separate a named parameter from its default value.

Fix lib/src/impl/io.dart. (-0.50 points)

Analysis of lib/src/impl/io.dart reported 1 hint:

line 30 col 23: Use = to separate a named parameter from its default value.

Fix additional 3 files with analysis or formatting issues. (-0.50 points)

Additional issues in the following files:

  • lib/src/impl/unsupported.dart (1 hint)
  • lib/src/types/firestore/document_reference.dart (Run dartfmt to format lib/src/types/firestore/document_reference.dart.)
  • lib/src/types/object.dart (Run dartfmt to format lib/src/types/object.dart.)

Maintenance suggestions

The package description is too short. (-19 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0