dart_fcm 0.0.24
dart_fcm: ^0.0.24 copied to clipboard

A wrapper package for setting up and consuming cloud notifications from firebase

4
likes
120/ 130
pub points
73%
popularity

We analyzed this package on Oct 25, 2021, and awarded it 120 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 9 out of 27 API elements (33.3 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 5 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:dart_fcm/dart_fcm.dart that imports:
  • package:dart_fcm/src/fcm.dart that imports:
  • package:dart_fcm/src/setup_on_message.dart that imports:
  • package:flutter_local_notifications/flutter_local_notifications.dart that declares support for platforms: Android, iOS, macOS.
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
debug_logger^0.0.230.0.230.0.23
firebase_core^1.3.01.8.01.8.0
firebase_messaging^10.0.210.0.910.0.9
flutterflutter0.0.00.0.0
flutter_local_notifications^8.0.08.2.09.0.1
rxdart^0.27.10.27.20.27.2
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
collection-1.15.01.15.0
firebase_core_platform_interface-4.0.14.0.1
firebase_core_web-1.1.01.1.0
firebase_messaging_web-2.0.72.0.7
flutter_web_plugins-0.0.00.0.0
js-0.6.30.6.3
logger-1.1.01.1.0
meta-1.7.01.7.0
path-1.8.01.8.0
platform-3.0.23.0.2
plugin_platform_interface-2.0.22.0.2
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^8.0.0` on flutter_local_notifications does not support the stable version `9.0.0`, that was published 20 days ago.

When flutter_local_notifications is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions flutter_local_notifications to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.