dart_express 0.5.3

Dart native

An unopinionated express-like HTTP framework built in Dart, includes the ability to render Mustache, Jael and HTML files, and simple routing.

5
likes
80 / 110
pub points
37 %
popularity

We analyzed this package on Oct 22, 2020, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/dart_express_example.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 26 out of 153 API elements (17.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:dart_express/dart_express.dart that imports:
  • package:mustache4dart/mustache4dart.dart that imports:
  • package:mustache4dart/mustache_context.dart that imports:
  • package:mustache4dart/src/reflect.dart that imports:
  • dart:mirrors
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
code_buffer^1.0.11.0.11.0.1
file^5.0.05.2.15.2.1
http^0.12.0+20.12.20.12.2
jael^2.0.22.0.22.0.2
jael_preprocessor^2.0.02.0.12.0.1
markdown^2.1.32.1.83.0.0
meta^1.1.71.2.31.2.3
mustache4dart^3.0.0-dev.0.03.0.0-dev.1.03.0.0-dev.1.0
path^1.6.41.7.01.7.0
path_to_regexp^0.2.10.2.10.3.0
symbol_table^2.0.02.0.02.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-11.0.011.0.0
analyzer-0.40.40.40.4
args-1.6.01.6.0
async-2.4.22.4.2
build-1.5.01.5.0
build_config-0.4.20.4.2
build_daemon-2.1.42.1.4
build_resolvers-1.4.21.4.2
build_runner-1.10.31.10.3
build_runner_core-6.0.36.0.3
built_collection-4.3.24.3.2
built_value-7.1.07.1.0
charcode-1.1.31.1.3
checked_yaml-1.0.21.0.2
cli_util-0.2.00.2.0
code_builder-3.5.03.5.0
collection-1.14.131.14.13
convert-2.1.12.1.1
crypto-2.1.52.1.5
dart_style-1.3.81.3.8
fixnum-0.10.110.10.11
glob-1.2.01.2.0
graphs-0.2.00.2.0
http_multi_server-2.2.02.2.0
http_parser-3.1.43.1.4
intl-0.16.10.16.1
io-0.3.40.3.4
js-0.6.20.6.2
json_annotation-3.1.03.1.0
logging-0.11.40.11.4
matcher-0.12.90.12.9
mime-0.9.70.9.7
node_interop-1.1.11.1.1
node_io-1.1.11.1.1
package_config-1.9.31.9.3
pool-1.4.01.4.0
pub_semver-1.4.41.4.4
pubspec_parse-0.1.50.1.5
quiver-2.1.32.1.3
reflectable-2.2.82.2.8
shelf-0.7.90.7.9
shelf_web_socket-0.2.30.2.3
source_span-1.7.01.7.0
stack_trace-1.9.51.9.5
stream_channel-2.0.02.0.0
stream_transform-1.2.01.2.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
timing-0.1.1+20.1.1+2
typed_data-1.2.01.2.0
watcher-0.9.7+150.9.7+15
web_socket_channel-1.1.01.1.0
yaml-2.2.12.2.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.1.3` on markdown does not support the latest published version `3.0.0`

pubspec.yaml:18:13

   ╷
18 │   markdown: ^2.1.3
   │             ^^^^^^
   ╵
The constraint `^0.2.1` on path_to_regexp does not support the latest published version `0.3.0`

pubspec.yaml:15:19

   ╷
15 │   path_to_regexp: ^0.2.1
   │                   ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

5
likes
80
pub points
37%
popularity

An unopinionated express-like HTTP framework built in Dart, includes the ability to render Mustache, Jael and HTML files, and simple routing.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

riegledevin@gmail.com

License

BSD (LICENSE)

Dependencies

code_buffer, file, http, jael, jael_preprocessor, markdown, meta, mustache4dart, path, path_to_regexp, symbol_table

More

Packages that depend on dart_express