dart_date 1.3.2 copy "dart_date: ^1.3.2" to clipboard
dart_date: ^1.3.2 copied to clipboard

Date manipulation library. DateTime extensions. Also includes an Interval object.

156
likes
130/ 140
pub points
96%
popularity

We analyzed this package 5 days ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

145 out of 182 API elements (79.7 %) have documentation comments.

Some symbols that are missing documentation: dart_date, dart_date.Date, dart_date.Date.operator +, dart_date.Date.operator -, dart_date.Date.operator <.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
intl >=0.17.0 <0.19.0 0.18.1 0.19.0
timeago ^3.0.2 3.6.1 3.6.1
Transitive dependencies
Package Constraint Compatible Latest
clock - 1.1.1 1.1.1
meta - 1.12.0 1.12.0
path - 1.9.0 1.9.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=0.17.0 <0.19.0` on intl does not support the stable version `0.19.0`.

Try running dart pub upgrade --major-versions intl to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.0.

Check the analysis log for details.

156
likes
130
pub points
96%
popularity

Publisher

verified publisherxantiagoma.com

Date manipulation library. DateTime extensions. Also includes an Interval object.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

intl, timeago

More

Packages that depend on dart_date