dart_coveralls 0.6.0+4

Dart native
Flutter Android iOS

Pub package to calculate coverage, format it to LCOV and send it to coveralls

0
likes
60 / 110
pub points
16 %
popularity

We analyzed this package on Sep 26, 2020, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 17 out of 143 API elements (11.9 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:dart_coveralls/dart_coveralls.dart that imports:
  • package:dart_coveralls/src/process_system.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 115 issues. Showing the first 2:

INFO: Unnecessary new keyword.

bin/dart_coveralls.dart:11:17

   ╷
11 │   var builder = new CommandLineHubBuilder()
   │                 ^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer bin/dart_coveralls.dart

INFO: Unnecessary new keyword.

bin/dart_coveralls.dart:12:25

   ╷
12 │     ..addPart("report", new ReportPart(),
   │                         ^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer bin/dart_coveralls.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args>=0.12.1 <2.0.01.6.01.6.0
coverage^0.12.00.12.40.14.1
crypto^2.0.12.1.52.1.5
file^5.0.05.2.15.2.1
http>=0.11.1+1 <0.12.00.11.3+170.12.2
logging>=0.9.2 <0.12.00.11.40.11.4
path^1.3.01.7.01.7.0
stack_trace^1.3.21.9.51.9.5
yaml^2.1.22.2.12.2.1
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.4.22.4.2
charcode-1.1.31.1.3
collection-1.14.131.14.13
convert-2.1.12.1.1
http_parser-3.1.43.1.4
intl-0.16.10.16.1
json_rpc_2-2.2.22.2.2
meta-1.2.31.2.3
package_config-1.9.31.9.3
pub_semver-1.4.41.4.4
source_span-1.7.01.7.0
stream_channel-2.0.02.0.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0
vm_service_client-0.2.6+30.2.6+3
web_socket_channel-1.1.01.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.12.0` on coverage does not support the latest published version `0.14.1`

pubspec.yaml:12:13

   ╷
12 │   coverage: ^0.12.0
   │             ^^^^^^^
   ╵
The constraint `>=0.11.1+1 <0.12.0` on http does not support the latest published version `0.12.2`

pubspec.yaml:15:9

   ╷
15 │   http: '>=0.11.1+1 <0.12.0'
   │         ^^^^^^^^^^^^^^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs