dart_codable 0.2.0
dart_codable: ^0.2.0 copied to clipboard

Implementing the Swift Codable Protocol. It provides the abstract classes Encodable, Decodable and Codable to extend a custom class with.

3
likes
80 / 130
pub points
38 %
popularity

We analyzed this package on Jun 18, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 9 out of 11 API elements (81.8 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:dart_codable/dart_codable.dart that imports:
  • dart:mirrors
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/dart_codable.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
reflectable^2.2.42.2.93.0.2
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-14.0.022.0.0
analyzer-0.41.11.7.1
args-1.6.02.1.1
async-2.7.02.7.0
build-1.6.22.0.2
build_config-0.4.51.0.0
build_daemon-2.1.103.0.0
build_resolvers-1.5.32.0.3
build_runner-1.11.12.0.4
build_runner_core-6.1.77.0.0
built_collection-5.1.05.1.0
built_value-8.1.08.1.0
charcode-1.3.11.3.1
checked_yaml-1.0.42.0.1
cli_util-0.2.00.3.0
clock-1.1.01.1.0
code_builder-3.7.04.0.0
collection-1.15.01.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.1
dart_style-1.3.122.0.1
file-5.2.16.1.2
fixnum-1.0.01.0.0
glob-1.2.02.0.1
graphs-0.2.02.0.0
http_multi_server-2.2.03.0.1
http_parser-4.0.04.0.0
intl-0.17.00.17.0
io-0.3.51.0.0
js-0.6.30.6.3
json_annotation-4.0.14.0.1
logging-0.11.41.0.1
matcher-0.12.100.12.10
meta-1.4.01.4.0
mime-1.0.01.0.0
node_interop-1.2.12.0.2
node_io-1.2.02.1.0
package_config-1.9.32.0.0
path-1.8.01.8.0
pedantic-1.11.11.11.1
pool-1.5.01.5.0
pub_semver-1.4.42.0.0
pubspec_parse-0.1.81.0.0
shelf-1.1.41.1.4
shelf_web_socket-0.2.4+11.0.1
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
stream_transform-2.0.02.0.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
timing-0.1.1+31.0.0
typed_data-1.3.01.3.0
watcher-0.9.7+151.0.0
web_socket_channel-1.2.02.1.0
yaml-3.1.03.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.2.4` on reflectable does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions reflectable to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.18.2, Dart 2.13.3.

3
likes
80
pub points
38%
popularity

Publisher

Unknown

Implementing the Swift Codable Protocol. It provides the abstract classes Encodable, Decodable and Codable to extend a custom class with.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

reflectable

More

Packages that depend on dart_codable