NOTE: This project is < 1.0.0 and is not considered stable yet
A command line tool that provides Dart 1 and Dart 2 compatible build and serve commands to ease the transition to Dart 2.
This tool is intended to be used as a transition tool when moving from Dart 1
to Dart 2. Since the
pub serve and
pub build commands are not present in
Dart 2, you can use dart_build to run the same command under both versions of
Dart, thus easing the transition to Dart 2. With dart_build you don't need to
modify your pubspec.yaml to add build_runner and build_web_compilers to be
able to build under Dart 2. Those dependencies are included by adding a
dependency on dart_build.
Add dart_build as a dev_dependency to your pubspec.yaml. When pub get solves you'll either the #.#.#+dart1 or the #.#.#+dart2 version depending on if you run the pub get command under Dart 1 or Dart 2.
dev_dependencies: dart_build: ^0.1.0
To run a build or serve simply swap out
pub run dart_build
in your usual commands. All of the command line options and arguments
are passed along, so all supported options of pub serve or build_runner
should be supported. For local use, adding an alias is recommended so you
don't need to type such a long command.
alias db='pub run dart_build'
pub run dart_build serve pub run dart_build build
or with the alias set up:
db serve db build
- Copy relevant build_runner pieces from webdev
- Add in dart 1 ability to run pub build & serve
- Update licensing to include Workiva + original Dart team license
Use this package as an executable
1. Install it
You can install the package from the command line:
$ pub global activate dart_build
2. Use it
The package has the following executables:
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Sep 20, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
- Dart: 2.5.0
- pana: 0.12.21
Detected platforms: Flutter, web, other
No platform restriction found in libraries.
Health issues and suggestions
bin/dart_build.dart. (-43.75 points)
bin/dart_build.dart failed with 2 errors:
line 125 col 18: Undefined name 'UTF8'.
line 131 col 18: Undefined name 'UTF8'.
Maintenance issues and suggestions
Support latest dependencies. (-20 points)
The version constraint in
pubspec.yaml does not support the latest published versions for 2 dependencies (
Package is getting outdated. (-16.71 points)
The package was last published 60 weeks ago.
|Dart SDK||>=1.24.2 <3.0.0|