dart_bloc_concurrency 1.1.0 copy "dart_bloc_concurrency: ^1.1.0" to clipboard
dart_bloc_concurrency: ^1.1.0 copied to clipboard

Custom event transformers. Built to be used with the bloc state management package.

0
likes
160/ 160
pub points
48%
popularity

We analyzed this package 2 days ago, and awarded it 160 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

5 out of 6 API elements (83.3 %) have documentation comments.

Some symbols that are missing documentation: dart_bloc_concurrency.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
bloc ^8.1.1 8.1.4 8.1.4
stream_transform ^2.1.0 2.1.0 2.1.0
Transitive dependencies
Package Constraint Compatible Latest
meta - 1.15.0 1.15.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Dart 3.4.3.

Check the analysis log for details.

0
likes
160
pub points
48%
popularity

Publisher

verified publishermj12358.dev

Custom event transformers. Built to be used with the bloc state management package.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

bloc, stream_transform

More

Packages that depend on dart_bloc_concurrency