dart_animation_controller 1.0.0 icon indicating copy to clipboard operation
dart_animation_controller: ^1.0.0 copied to clipboard

Flutter independent AnimationController

0
likes
65/ 130
pub points
32%
popularity

We analyzed this package 4 days ago, and awarded it 65 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
5 / 20icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

No `CHANGELOG.md` found.

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 5 out of 19 API elements (26.3 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/dart_animation_controller.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/src/dart_animation_controller.dart doesn't match the Dart formatter.

To format your files run: dart format .

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
abstract_dart^0.0.30.0.31.0.2
Transitive dependencies
PackageConstraintCompatibleLatest
decimal-0.3.52.2.0
rational-0.3.82.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.0.3` on abstract_dart does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions abstract_dart to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>2.2.2 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.13, Dart 2.17.5.