dart_algorand 0.9.7
dart_algorand: ^0.9.7 copied to clipboard

Dart native
Flutter Android iOS Linux macOS Windows

A dart library for interacting with the Algorand network. Algorand is an open source permissionless public blockchain based on a pure proof-of-stake consensus protocol.

1
likes
80 / 110
pub points
0 %
popularity

We analyzed this package on Feb 27, 2021, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 289 out of 1306 API elements (22.1 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:dart_algorand/dart_algorand.dart that imports:
  • package:dart_algorand/src/asset_transfer_txn.dart that imports:
  • package:dart_algorand/src/transaction.dart that imports:
  • package:dart_algorand/src/encoding.dart that imports:
  • package:msgpack_dart/msgpack_dart.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

INFO: Unused import: 'package:built_collection/built_collection.dart'.

lib/src/kmd/model/apiv1_post_master_key_export_response.dart:1:8

  ╷
1 │ import 'package:built_collection/built_collection.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/kmd/model/apiv1_post_master_key_export_response.dart

INFO: Unused import: 'package:built_collection/built_collection.dart'.

lib/src/kmd/model/create_wallet_request.dart:1:8

  ╷
1 │ import 'package:built_collection/built_collection.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/kmd/model/create_wallet_request.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
base32^1.1.11.1.21.1.2
built_collection^4.3.24.3.25.0.0
built_value^7.0.97.1.08.0.0
collection^1.14.111.14.131.15.0
convert^2.1.12.1.13.0.0
dio^3.0.93.0.103.0.10
equatable^1.1.01.2.61.2.6
http^0.12.00.12.20.13.0
meta^1.1.81.2.41.3.0
msgpack_dart^0.0.60.0.70.0.7
pinenacl^0.1.20.1.50.1.5
pointycastle^1.0.21.0.22.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
bech32-0.1.20.1.2
charcode-1.1.31.2.0
fixnum-0.10.111.0.0
http_parser-3.1.44.0.0
matcher-0.12.90.12.10
path-1.7.01.8.0
quiver-2.1.53.0.0
source_span-1.7.01.8.1
stack_trace-1.9.61.10.0
string_scanner-1.0.51.1.0
term_glyph-1.1.01.2.0
typed_data-1.2.01.3.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 5 issues. Showing the first 2:

The constraint `^4.3.2` on built_collection does not support the latest published version `5.0.0`

pubspec.yaml:21:21

   ╷
21 │   built_collection: ^4.3.2
   │                     ^^^^^^
   ╵
The constraint `^7.0.9` on built_value does not support the latest published version `8.0.0`

pubspec.yaml:20:16

   ╷
20 │   built_value: ^7.0.9
   │                ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.14.10, Dart 2.10.5.

1
likes
80
pub points
0%
popularity

A dart library for interacting with the Algorand network. Algorand is an open source permissionless public blockchain based on a pure proof-of-stake consensus protocol.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

alvistar@gmail.com

License

MIT (LICENSE.txt)

Dependencies

base32, built_collection, built_value, collection, convert, dio, equatable, http, meta, msgpack_dart, pinenacl, pointycastle

More

Packages that depend on dart_algorand