dart_3des 1.0.1
dart_3des: ^1.0.1 copied to clipboard

Triple DES and DES block cipher implementation ported from CryptoJS

dart_3des #

Triple DES and DES block cipher implementation ported from CryptoJS

Build Status

This is ported from CryptoJS. The latest version can be found bryx/cryptojs or sytelus/CryptoJS

Installing #

Add the dependency

In your pubspec.yaml file add:

  1. dart_3des: 1.0.0
  • If in flutter
  1. run flutter pub get
  • If in dart
  1. run dart pub get

Example #

import 'package:dart_3des/dart_3des.dart';

main() {
  var key = "cipher";
  var blockCipher = new BlockCipher(new DESEngine(), key);
  var message = "Uganda is a really difficult country";
  var ciphertext = blockCipher.encodeB64(message);
  var decoded = blockCipher.decodeB64(ciphertext);

  print("key: $key");
  print("message: $message");
  print("ciphertext (base64): $ciphertext");
  print("decoded ciphertext: $decoded");
}
5
likes
120
pub points
36%
popularity

Triple DES and DES block cipher implementation ported from CryptoJS

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

More

Packages that depend on dart_3des