A tool to migrate API usage to Dart 2.
What does it do? #
dart2_fix is a command line utility that can automatically migrate some Dart 1 API usages in your
source code to Dart 2 ones. Currently, it focuses on updating deprecated constant names; for example:
For more information about preparing your code for Dart 2, please see the Dart 2 migration guide.
How do I use it? #
To install, run
pub global activate dart2_fix. Then, from your project directory, run:
pub global run dart2_fix
When run without any arguments, it will check your project, but will not make changes; it'll indicate what would be changed if asked to make modifications. For example:
test/test/runner/load_suite_test.dart line 56 • Duration.ZERO => Duration.zero line 60 • Duration.ZERO => Duration.zero line 86 • Duration.ZERO => Duration.zero test/tool/host.dart line 169 • JSON => json line 173 • JSON => json Found 5 fixes in 2.3s. To apply these fixes, run again using the --apply argument.
To actually modify your project source code, run with the
--apply argument (
pub global run dart2_fix --apply):
Updating test... test/test/runner/load_suite_test.dart 3 fixes applied for Duration.ZERO => Duration.zero test/tool/host.dart 2 fixes applied for JSON => json Applied 5 fixes in 1.9s.
What about Flutter code? #
To run this tool on Flutter code, use:
flutter packages pub global activate dart2_fix
then - to check your code - run:
flutter packages pub global run dart2_fix
and to apply fixes, run:
flutter packages pub global run dart2_fix --apply
Will this make all of my code Dart 2 compliant? #
No. Currently this only fixes the renaming of various deprecated constant
names. Some of the less uniform constant renamings are not handled by this
tool. For example
Endianness.BIG_ENDIAN has been renamed to
this will not be caught. After running this tool, remaining issues can be found
by running the dart analyzer (or flutter analyze) and fixing any deprecation
I'm getting new static (or runtime errors) after running dart2_fix, what went wrong? #
This tool can't catch conflicts between the new constant names and any fields or
local variables that you might have in scope. If you get new analysis warnings
or runtime failures after running this tool, check to see whether one of the
changes made has caused a naming conflict with something else in scope. The
most common cause of this is having a local variable named
json in a scope
JSON.decode gets renamed to
json.decode. To help with fixing these
kinds of conflicts, the following top level members have been added to
base64UrlEncode. These top level members are equivalent to
json.decode, etc, and can be used to avoid naming conflicts where required.
Features and bugs #
Please file feature requests and bugs at the issue tracker.
- Upgraded dependencies for Dart 2.
- Support more constants related to HTTP.
- Add support for removing
jsonEncode(and similarly for jsonDecode, base64Encode, and base64Decode).
- Add support for deprecated
- Add a
dart2_fixpub run entry-point.
- Updates to the latest version of packages.
- Added an
- Made the tool work under Dart 2 runtime semantics.
- Updated when we print timing info for the tool.
- Added an SDK lower bound of
- Added a
- Fix an issue converting
- Fix an issue converting
- Initial version.
Use this package as an executable
1. Install it
You can install the package from the command line:
$ pub global activate dart2_fix
2. Use it
The package has the following executables:
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Jan 27, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
- Dart: 2.7.1
- pana: 0.13.4
lib/src/dart_fix.dart. (-9.54 points)
lib/src/dart_fix.dart reported 20 hints, including:
line 17 col 26: Unnecessary new keyword.
line 20 col 25: Unnecessary new keyword.
line 51 col 12: Unnecessary new keyword.
line 56 col 33: Unnecessary new keyword.
line 60 col 14: Unnecessary new keyword.
lib/src/deprecation_analysis_server.dart. (-5.84 points)
lib/src/deprecation_analysis_server.dart reported 12 hints, including:
line 25 col 27: Unnecessary new keyword.
line 26 col 5:
Future results in
async function bodies must be
awaited or marked
line 32 col 51: Unnecessary new keyword.
line 34 col 10: The value of the local variable 'hadServerError' isn't used.
line 40 col 13: Unnecessary new keyword.
lib/src/deprecation_analyzer.dart. (-2.48 points)
lib/src/deprecation_analyzer.dart reported 5 hints:
line 21 col 3: Prefer using /// for doc comments.
line 33 col 9: Unnecessary new keyword.
line 35 col 17: 'locateContexts' is deprecated and shouldn't be used.
line 37 col 34: Unnecessary new keyword.
line 73 col 10: Unnecessary new keyword.
lib/src/changes.dart. (-1.99 points)
lib/src/changes.dart reported 4 hints:
line 358 col 12: Unnecessary new keyword.
line 367 col 12: Unnecessary new keyword.
line 372 col 11: Unnecessary new keyword.
line 438 col 12: Unnecessary new keyword.
lib/src/model.dart. (-0.50 points)
lib/src/model.dart reported 1 hint:
line 57 col 32: Unnecessary new keyword.
Maintenance issues and suggestions
Support latest dependencies. (-20 points)
The version constraint in
pubspec.yaml does not support the latest published versions for 2 dependencies (
Package is getting outdated. (-51.78 points)
The package was last published 79 weeks ago.
The package description is too short. (-20 points)
Add more detail to the
description field of
pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.
|Dart SDK||>=2.0.0-dev.17.0 <3.0.0|