A Flutter package to automatically update your pubspec dependencies in your project.
Add the following dependencies to your
dev_dependencies: dapackages: ^1.0.0
Run the updater #
flutter pub pub run dapackages:dapackages.dart PUBSPEC_FILE_PATH
flutter pub pub run dapackages:dapackages.dart ./pubspec.yaml
[1.0.0] - 2019-08-08
- First version
[1.1.1] - 2019-10-16
- Not updating fixed dependencies
Example available in the main README.
Use this package as a library
1. Depend on it
Add this to your package's pubspec.yaml file:
dependencies: dapackages: ^1.1.1
2. Install it
You can install packages from the command line:
$ flutter pub get
Alternatively, your editor might support
flutter pub get.
Check the docs for your editor to learn more.
3. Import it
Now in your Dart code, you can use:
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Dec 7, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
- Dart: 2.6.1
- pana: 0.12.21
- Flutter: 1.9.1+hotfix.6
Detected platforms: Flutter
References Flutter, and has no conflicting libraries.
Health issues and suggestions
Document public APIs. (-1 points)
1 out of 1 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.
|Dart SDK||>=2.5.0 <3.0.0|