Dapackages

A Flutter package to automatically update your pubspec dependencies in your project.

Installation

Add the following dependencies to your pubspec.yaml:

dev_dependencies:
  dapackages: ^1.0.0

Run the updater

flutter pub pub run dapackages:dapackages.dart PUBSPEC_FILE_PATH

For example:

flutter pub pub run dapackages:dapackages.dart ./pubspec.yaml

Libraries

dapackages