dao 0.0.4
dao: ^0.0.4 copied to clipboard

A starting point for Dart Process Api package, for Using commondline app to Easyly access start stop restart commands, see demo or examples.

0
likes
50/ 130
pub points
27%
popularity

We analyzed this package on Dec 1, 2021, and awarded it 50 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://gitee.com/darto/dao was unreachable.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 45 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:dao/dao.dart that imports:
  • package:dao/src/dao_base.dart that imports:
  • package:mongo_dart/mongo_dart.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/dao_base.dart doesn't match the Dart formatter.

To format your files run: dart format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
alm^0.0.60.0.81.0.0
convert^2.1.12.1.13.0.1
mongo_dart^0.4.20.4.40.7.4
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
basic_utils-2.7.13.9.1
bson-0.3.41.0.4
characters-1.2.01.2.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
crypto-2.1.53.0.1
fixnum-0.10.111.0.0
http-0.12.20.13.4
http_parser-3.1.44.0.0
json_annotation-3.1.14.4.0
logging-0.11.41.0.2
meta-1.7.01.7.0
mongo_dart_query-0.4.21.0.2
more-2.8.03.3.0
path-1.8.01.8.0
pedantic-1.11.11.11.1
pointycastle-2.0.13.4.0
pool-1.5.01.5.0
rational-0.3.82.0.0
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
uuid-2.2.23.0.5

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^0.0.6` on alm does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions alm to update the constraint.

The constraint `^2.1.1` on convert does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions convert to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.8.1 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Dart 2.14.4.

0
likes
50
pub points
27%
popularity

A starting point for Dart Process Api package, for Using commondline app to Easyly access start stop restart commands, see demo or examples.

Homepage (missing)

Documentation

API reference

License

unknown (LICENSE)

Dependencies

alm, convert, mongo_dart

More

Packages that depend on dao