danger_dart 2.0.0 copy "danger_dart: ^2.0.0" to clipboard
danger_dart: ^2.0.0 copied to clipboard

Danger Dart, tool to help you reviewing the code.

0
likes
110/ 140
pub points
6%
popularity

We analyzed this package 3 days ago, and awarded it 110 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

67 out of 100 API elements (67.0 %) have documentation comments.

Some symbols that are missing documentation: ci_command, ci_command.CICommand, ci_command.CICommand.CICommand, danger_dart, danger_dart.logger.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:danger_dart/danger_dart.dart that imports:
  • package:danger_dart/commands/process_command.dart that imports:
  • package:danger_core/src/utils/danger_isolate_receiver.dart that imports:
  • dart:isolate
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
args ^2.4.2 2.4.2 2.4.2
danger_core ^2.0.0 2.0.0 2.0.0
fimber ^0.7.0 0.7.0 0.7.0
meta ^1.10.0 1.12.0 1.12.0
path ^1.8.3 1.9.0 1.9.0
process_run ^0.13.1 0.13.3+1 0.14.2
Transitive dependencies
Package Constraint Compatible Latest
collection - 1.18.0 1.18.0
pub_semver - 2.1.4 2.1.4
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
synchronized - 3.1.0+1 3.1.0+1
term_glyph - 1.2.1 1.2.1
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.13.1` on process_run does not support the stable version `0.14.0`.

Try running dart pub upgrade --major-versions process_run to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.0.

Check the analysis log for details.

0
likes
110
pub points
6%
popularity

Publisher

verified publisherdanger.systems

Danger Dart, tool to help you reviewing the code.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

args, danger_core, fimber, meta, path, process_run

More

Packages that depend on danger_dart