dalk_sdk 0.0.6
dalk_sdk: ^0.0.6 copied to clipboard

Dalk.io sdk, add a realtime chat feature on any Dart/Flutter app

1
likes
80 / 130
pub points
0 %
popularity

We analyzed this package on Aug 3, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://dalk.io was unreachable.

Documentation URL doesn't exist.

At the time of the analysis https://dalk.io/doc/api/ was unreachable.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 57 out of 73 API elements (78.1 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime native

Because:

  • package:dalk_sdk/sdk_interop.dart that imports:
  • package:js/js_util.dart that imports:
  • dart:js_util
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args^1.5.21.6.02.2.0
freezed_annotation^0.7.10.7.10.14.3
js^0.6.1+10.6.30.6.3
json_rpc_2^2.1.12.2.23.0.1
logging^0.11.40.11.41.0.1
meta^1.1.81.7.01.7.0
retry^3.0.0+13.1.03.1.0
stream_channel^2.0.02.1.02.1.0
web_socket_channel^1.1.01.2.02.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.12.8.1
collection-1.15.01.15.0
crypto-3.0.13.0.1
json_annotation-3.1.14.1.0
path-1.8.01.8.0
stack_trace-1.10.01.10.0
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 5 issues. Showing the first 2:

The constraint `^1.5.2` on args does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions args to update the constraint.

The constraint `^0.7.1` on freezed_annotation does not support the stable version `0.11.0`.

Try running dart pub upgrade --major-versions freezed_annotation to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.3.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.19.0, Dart 2.13.4.