dabric 0.1.32

Dabric #

Helpers for minecraft datapack development

/build #

Lots of extra helpers for setting up a new project.

build #

Helps you build the code

project #

The top level part of a project

pack #

A subdivision of a project

/util #

Lots of useful util helpers for minecraft

conds #

delay #

detect #

stat #

logger #

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  dabric: ^0.1.32

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:dabric/utils/conds.dart';
import 'package:dabric/utils/stat.dart';
import 'package:dabric/build/index.dart';
import 'package:dabric/build/pack.dart';
import 'package:dabric/build/project.dart';
import 'package:dabric/utils/delay.dart';
import 'package:dabric/utils/detect.dart';
import 'package:dabric/utils/logger.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

We analyzed this package on Dec 7, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.1
  • pana: 0.12.21

Platforms

Detected platforms:

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.6.1.
 
 Because dabric requires SDK version >=2.2.2 <=2.3.0, version solving failed.

Health suggestions

Format lib/build/index.dart.

Run dartfmt to format lib/build/index.dart.

Format lib/build/pack.dart.

Run dartfmt to format lib/build/pack.dart.

Format lib/build/project.dart.

Run dartfmt to format lib/build/project.dart.

Fix additional 5 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/utils/conds.dart (Run dartfmt to format lib/utils/conds.dart.)
  • lib/utils/delay.dart (Run dartfmt to format lib/utils/delay.dart.)
  • lib/utils/detect.dart (Run dartfmt to format lib/utils/detect.dart.)
  • lib/utils/logger.dart (Run dartfmt to format lib/utils/logger.dart.)
  • lib/utils/stat.dart (Run dartfmt to format lib/utils/stat.dart.)

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Support future stable Dart 2 SDKs in pubspec.yaml. (-20 points)

The SDK constraint in pubspec.yaml doesn't allow future stable Dart 2.x SDK releases.

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Provide a file named CHANGELOG.md. (-20 points)

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Homepage URL doesn't exist. (-20 points)

At the time of the analysis the homepage field https://github.com/strootje/dabric was unreachable.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and dabric.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

The package description is too short. (-2 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.2.2 <=2.3.0