d20 0.2.0+test-github-actions-1

Dart native js
Flutter Android iOS web

D20 is a Dart library for RPG dice rolling. Supports standard notation (like "2d12", "d6+5" and "2d20-L").

1
likes
100 / 110
pub points
35 %
popularity

We analyzed this package on Sep 25, 2020, and awarded it 100 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 24 out of 27 API elements (88.9 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
math_expressions^1.0.01.1.12.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
vector_math-2.0.82.0.8

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.0` on math_expressions does not support the latest published version `2.0.1`

pubspec.yaml:13:21

   ╷
13 │   math_expressions: ^1.0.0
   │                     ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

1
likes
100
pub points
35%
popularity

Publisher

borges.dev

D20 is a Dart library for RPG dice rolling. Supports standard notation (like "2d12", "d6+5" and "2d20-L").

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

math_expressions

More

Packages that depend on d20