cw_sdk_dart 0.1.1-alpha.1 icon indicating copy to clipboard operation
cw_sdk_dart: ^0.1.1-alpha.1 copied to clipboard

An unofficial sdk for the Cryptowatch API, currently in alpha. Features full support for the REST API.

2
likes
100/ 140
pub points
0%
popularity

We analyzed this package 3 days ago, and awarded it 100 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-2-Clause.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 143 out of 167 API elements (85.6 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 21 issues. Showing the first 2:

INFO: 'List.List' is deprecated and shouldn't be used. Use a list literal, [], or the List.filled constructor instead.

lib/src/client/rest/helpers.dart:138:16

    ╷
138 │   var orders = List<common.PublicOrder>();
    │                ^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/client/rest/helpers.dart

INFO: 'List.List' is deprecated and shouldn't be used. Use a list literal, [], or the List.filled constructor instead.

lib/src/client/rest/helpers.dart:199:17

    ╷
199 │   var candles = List<common.Candle>();
    │                 ^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/client/rest/helpers.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
collection^1.14.121.17.11.17.1
http^0.12.10.12.20.13.5
quiver^2.1.32.1.53.2.1
test^1.14.31.16.51.22.2
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-22.0.052.0.0
analyzer-1.7.25.4.0
args-2.3.22.3.2
async-2.10.02.10.0
boolean_selector-2.1.12.1.1
charcode-1.3.11.3.1
cli_util-0.3.50.3.5
convert-3.1.13.1.1
coverage-1.0.31.6.2
crypto-3.0.23.0.2
file-6.1.46.1.4
glob-2.1.12.1.1
http_multi_server-3.2.13.2.1
http_parser-3.1.44.0.2
io-1.0.41.0.4
js-0.6.70.6.7
logging-1.1.11.1.1
matcher-0.12.100.12.14
meta-1.9.01.9.0
mime-1.0.01.0.4
node_preamble-1.4.132.0.1
package_config-2.1.02.1.0
path-1.8.31.8.3
pedantic-1.11.11.11.1
pool-1.5.11.5.1
pub_semver-2.1.32.1.3
shelf-0.7.91.4.0
shelf_packages_handler-2.0.13.0.1
shelf_static-0.2.9+21.1.1
shelf_web_socket-0.2.4+11.0.3
source_map_stack_trace-2.1.12.1.1
source_maps-0.10.110.10.11
source_span-1.9.11.9.1
stack_trace-1.11.01.11.0
stream_channel-2.1.12.1.1
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
test_api-0.2.190.4.18
test_core-0.3.150.4.22
typed_data-1.3.11.3.1
vm_service-6.2.010.1.2
watcher-1.0.21.0.2
web_socket_channel-2.3.02.3.0
webkit_inspection_protocol-1.2.01.2.0
yaml-3.1.13.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.12.1` on http does not support the stable version `0.13.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

The constraint `^2.1.3` on quiver does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions quiver to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.4.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.25, Dart 2.19.1.

2
likes
100
pub points
0%
popularity

Publisher

verified publisher iconemile.bz

An unofficial sdk for the Cryptowatch API, currently in alpha. Features full support for the REST API.

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.BSD-2-Clause (LICENSE)

Dependencies

collection, http, quiver, test

More

Packages that depend on cw_sdk_dart