customized_editing_controllers 1.0.1 icon indicating copy to clipboard operation
customized_editing_controllers: ^1.0.1 copied to clipboard

This library contains customized editing controllers.

0
likes
75/ 140
pub points
0%
popularity

We analyzed this package 1 hour ago, and awarded it 75 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
15 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

No CHANGELOG.md found.

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 12 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/customized_editing_controllers.dart doesn't match the Dart formatter.

To format your files run: flutter format .

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^0.39.40.39.175.2.0
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-7.0.050.0.0
args-1.6.02.3.1
async-2.10.02.10.0
characters-1.2.11.2.1
charcode-1.3.11.3.1
cli_util-0.2.00.3.5
clock-1.1.11.1.1
collection-1.16.01.17.0
convert-2.1.13.1.1
crypto-2.1.53.0.2
csslib-0.16.20.17.2
file-5.2.16.1.4
glob-1.2.12.1.1
html-0.14.0+40.15.1
intl-0.17.00.17.0
js-0.6.50.6.5
material_color_utilities-0.1.50.2.0
meta-1.8.01.8.0
node_interop-1.2.12.1.0
node_io-1.2.02.2.0
package_config-1.9.32.1.0
path-1.8.21.8.2
pedantic-1.11.11.11.1
pub_semver-1.4.42.1.3
sky_engine-0.0.990.0.99
source_span-1.9.11.9.1
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
vector_math-2.1.22.1.4
watcher-0.9.7+151.0.2
yaml-2.2.13.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint ^0.39.4 on analyzer does not support the stable version 0.40.0.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint >=2.0.0 <3.0.0) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.21, Flutter 3.3.9, Dart 2.18.5.

0
likes
75
pub points
0%
popularity

Publisher

verified publisher iconvo9312.co

This library contains customized editing controllers.

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

analyzer, flutter

More

Packages that depend on customized_editing_controllers