custom_package 1.0.1
custom_package: ^1.0.1 copied to clipboard

Contoh penggunaan source generation.

2
likes
55 / 130
pub points
0 %
popularity

We analyzed this package on Jun 17, 2021, and awarded it 55 pub points (of a possible 130):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis http://mylabstudio.info was unreachable.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:25:49

   ╷
25 │ <p>Please file feature requests and bugs at the <a href="http://example.com/issues/replaceme">issue tracker</a>.</p>
   │                                                 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 7 API elements (14.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/builders/bujur_sangkar_generator.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/src/builders/lingkaran_generator.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^0.39.40.39.171.7.1
build^1.2.21.3.02.0.2
build_runner^1.8.11.10.22.0.4
source_gen^0.9.50.9.7+11.0.2
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-7.0.022.0.0
args-1.6.02.1.1
async-2.7.02.7.0
build_config-0.4.21.0.0
build_daemon-2.1.103.0.0
build_resolvers-1.3.112.0.3
build_runner_core-6.0.17.0.0
built_collection-5.1.05.1.0
built_value-8.0.68.0.6
charcode-1.3.11.3.1
checked_yaml-1.0.42.0.1
cli_util-0.2.00.3.0
clock-1.1.01.1.0
code_builder-3.7.04.0.0
collection-1.15.01.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.1
csslib-0.16.20.17.0
dart_style-1.3.62.0.1
file-5.2.16.1.2
fixnum-1.0.01.0.0
glob-1.2.02.0.1
graphs-0.2.02.0.0
html-0.14.0+40.15.0
http_multi_server-2.2.03.0.1
http_parser-3.1.44.0.0
intl-0.17.00.17.0
io-0.3.51.0.0
js-0.6.30.6.3
json_annotation-3.1.14.0.1
logging-0.11.41.0.1
matcher-0.12.100.12.10
meta-1.4.01.4.0
mime-0.9.71.0.0
node_interop-1.2.12.0.2
node_io-1.2.02.1.0
package_config-1.9.32.0.0
path-1.8.01.8.0
pool-1.5.01.5.0
pub_semver-1.4.42.0.0
pubspec_parse-0.1.81.0.0
shelf-0.7.91.1.4
shelf_web_socket-0.2.4+11.0.1
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
stream_transform-1.2.02.0.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
timing-0.1.1+31.0.0
typed_data-1.3.01.3.0
watcher-0.9.7+151.0.0
web_socket_channel-1.2.02.1.0
yaml-2.2.13.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^0.39.4` on analyzer does not support the stable version `0.40.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

The constraint `^1.2.2` on build does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions build to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.17.1, Dart 2.13.1.

2
likes
55
pub points
0%
popularity

Publisher

Unknown

Contoh penggunaan source generation.

Homepage

Documentation

API reference

License

BSD (LICENSE)

Dependencies

analyzer, build, build_runner, source_gen

More

Packages that depend on custom_package