cuma_webview 0.1.1 copy "cuma_webview: ^0.1.1" to clipboard
cuma_webview: ^0.1.1 copied to clipboard

Plugin that allow Flutter to communicate with a native Webview.

0
likes
15/ 160
pub points
0%
popularity

We analyzed this package 6 days ago, and awarded it 15 pub points (of a possible 160):

failed
Follow Dart file conventions
5 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: cuma_webview,
    • contains a version property, and,
    • does not contain a publish_to property.

Repository has no matching pubspec.yaml with name: cuma_webview.

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

`CHANGELOG.md` is empty.

Changelog entries help developers follow the progress of your package. Check out the Dart conventions for Maintaining a package changelog.

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

failed
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

Dependency resolution failed, unable to run dartdoc.

10/10 points: Package has an example

failed
Platform support
0 / 20trigger folding of the section

0/20 points: Supports 0 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

These platforms are not supported:

Tag detection failed.

Exception: Couldn't read pubspec.yaml in /Users/ririlab/flutter/packages/flutter. PathNotFoundException: Cannot open file, path = '/Users/ririlab/flutter/packages/flutter/pubspec.yaml' (OS Error: No such file or directory, errno = 2)

Tag detection failed.

Exception: Couldn't read pubspec.yaml in /Users/ririlab/flutter/packages/flutter. PathNotFoundException: Cannot open file, path = '/Users/ririlab/flutter/packages/flutter/pubspec.yaml' (OS Error: No such file or directory, errno = 2)

Package does not support platform `Windows`.

Because:

  • package:cuma_webview/cuma_webview.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:cuma_webview/cuma_webview.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:cuma_webview/cuma_webview.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:cuma_webview/cuma_webview.dart that declares support for platforms: Android, iOS.
failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

  • Running flutter pub outdated failed with the following output:
The lower bound of "sdk: '>=2.0.0 <3.0.0'" must be 2.12.0'
or higher to enable null safety.
failed
Support up-to-date dependencies
0 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Sdk constraint doesn't support current Dart version 3.4.1. Cannot run `flutter pub outdated`.

pubspec.yaml:14:8

   ╷
14 │   sdk: ">=2.0.0 <3.0.0"
   │        ^^^^^^^^^^^^^^^^
   ╵

0/10 points: Package supports latest stable Dart and Flutter SDKs

Sdk constraint doesn't support current Dart version 3.4.1.

pubspec.yaml:14:8

   ╷
14 │   sdk: ">=2.0.0 <3.0.0"
   │        ^^^^^^^^^^^^^^^^
   ╵

Try widening the upper boundary of the constraint.

The current SDK constraint does not allow the Dart version used by the latest stable Flutter (3.4.1)

pubspec.yaml:14:8

   ╷
14 │   sdk: ">=2.0.0 <3.0.0"
   │        ^^^^^^^^^^^^^^^^
   ╵

0/20 points: Compatible with dependency constraint lower bounds

flutter pub downgrade failed with:

OUT:
Resolving dependencies...
ERR:
The lower bound of "sdk: '>=2.0.0 <3.0.0'" must be 2.12.0'
or higher to enable null safety.

The current Dart SDK (3.4.1) only supports null safety.

For details, see https://dart.dev/null-safety

Run flutter pub downgrade and then flutter analyze to reproduce the above problem.

You may run dart pub upgrade --tighten to update your dependency constraints, see dart.dev/go/downgrade-testing for details.

Analyzed with Pana 0.22.5, Flutter 3.22.1, Dart 3.4.1.

Check the analysis log for details.

0
likes
15
pub points
0%
popularity

Publisher

verified publishercuma.co.kr

Plugin that allow Flutter to communicate with a native Webview.

Repository (GitHub)
View/report issues

Dependencies

flutter

More

Packages that depend on cuma_webview