crypto_keys 0.3.0 icon indicating copy to clipboard operation
crypto_keys: ^0.3.0 copied to clipboard

A library for doing cryptographic signing/verifying and encrypting/decrypting.

21
likes
120/ 130
pub points
87%
popularity

We analyzed this package 4 days ago, and awarded it 120 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 54 out of 83 API elements (65.1 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 13 issues. Showing the first 2:

INFO: Name non-constant identifiers using lowerCamelCase.

lib/src/algorithms.dart:31:9

   ╷
31 │   final encrypting_aes_cbc = AlgorithmIdentifier._(
   │         ^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/algorithms.dart

INFO: 'AESFastEngine' is deprecated and shouldn't be used.

lib/src/algorithms.dart:34:51

   ╷
34 │           pc.PKCS7Padding(), pc.CBCBlockCipher(pc.AESFastEngine())));
   │                                                   ^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/algorithms.dart

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
collection^1.14.131.16.01.16.0
meta^1.3.01.8.01.8.0
pointycastle^3.0.03.6.13.6.1
quiver^3.0.03.1.03.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
convert-3.0.23.0.2
js-0.6.40.6.4
matcher-0.12.120.12.12
path-1.8.21.8.2
stack_trace-1.10.01.10.0
typed_data-1.3.11.3.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.15, Dart 2.17.6.

21
likes
120
pub points
87%
popularity

Publisher

verified publisher iconappsup.be

A library for doing cryptographic signing/verifying and encrypting/decrypting.

Homepage

Documentation

API reference

License

Icon for licenses.BSD-3-Clause (LICENSE)

Dependencies

collection, meta, pointycastle, quiver

More

Packages that depend on crypto_keys