cruzawl 1.0.9+9

Library for the CRUZ cryptocurrency and the cruzbit.1 network.

0
likes
70 / 110
pub points
18 %
popularity

We analyzed this package on Oct 29, 2020, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 590 out of 922 API elements (64.0 %) have documentation comments.
Support multiple platforms
0 / 20

0/20 points: Supports 0 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 27 issues. Showing the first 2:

INFO: Unnecessary new keyword.

lib/sha3.dart:14:37

   ╷
14 │   static final RegExp _NAME_REGEX = new RegExp(r"^SHA-3\/([0-9]+)$");
   │                                     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/sha3.dart

INFO: Unnecessary new keyword.

lib/sha3.dart:17:47

   ╷
17 │     static final FactoryConfig FACTORY_CONFIG = new DynamicFactoryConfig(
   │ ┌───────────────────────────────────────────────^
18 │ │       Digest,
19 │ │       _NAME_REGEX,
20 │ │       (_, final Match match) => () {
21 │ │             int bitLength = int.parse(match.group(1));
22 │ │             return new SHA3Digest(bitLength);
23 │ │           });
   │ └────────────^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/sha3.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
bip39^1.0.31.0.31.0.3
collection^1.14.111.14.131.14.13
convert^2.1.12.1.12.1.1
ed25519_hd_key^1.0.11.0.11.0.1
fixnum^0.10.90.10.110.10.11
json_annotation^3.0.03.1.03.1.0
meta^1.1.61.2.31.2.3
pedantic^1.8.01.9.21.9.2
pointycastle^1.0.11.0.22.0.0
sembast^2.0.12.4.7+72.4.7+7
tweetnacl^0.3.20.3.20.3.2
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.1.31.1.3
crypto-2.1.52.1.5
hex-0.1.20.1.2
path-1.7.01.7.0
synchronized-2.2.0+22.2.0+2
typed_data-1.2.01.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.1` on pointycastle does not support the latest published version `2.0.0`

pubspec.yaml:19:17

   ╷
19 │   pointycastle: ^1.0.1
   │                 ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs