crossfire_flutter 2.0.0+3

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 27

crossfire_flutter #

Cross-platform APIs for Firebase.

see the project page for usage examples

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  crossfire_flutter: ^2.0.0+3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:crossfire_flutter/crossfire_flutter.dart';
  
Version Uploaded Documentation Archive
3.0.0 Mar 4, 2019 Go to the documentation of crossfire_flutter 3.0.0 Download crossfire_flutter 3.0.0 archive
2.1.0 Mar 12, 2019 Go to the documentation of crossfire_flutter 2.1.0 Download crossfire_flutter 2.1.0 archive
2.0.0+3 Sep 25, 2018 Go to the documentation of crossfire_flutter 2.0.0+3 Download crossfire_flutter 2.0.0+3 archive
2.0.0+2 Sep 13, 2018 Go to the documentation of crossfire_flutter 2.0.0+2 Download crossfire_flutter 2.0.0+2 archive
2.0.0 Aug 21, 2018 Go to the documentation of crossfire_flutter 2.0.0 Download crossfire_flutter 2.0.0 archive
1.0.0+1 Jul 11, 2018 Go to the documentation of crossfire_flutter 1.0.0+1 Download crossfire_flutter 1.0.0+1 archive
1.0.0 Jul 11, 2018 Go to the documentation of crossfire_flutter 1.0.0 Download crossfire_flutter 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
29
Health:
Code health derived from static analysis. [more]
41
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
27
Learn more about scoring.

We analyzed this package on May 8, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.0
  • pana: 0.12.15
  • Flutter: 1.5.8

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Fix lib/crossfire_flutter.dart. (-58.02 points)

Analysis of lib/crossfire_flutter.dart failed with 3 errors, 1 hint:

line 155 col 7: Missing concrete implementation of FirebaseCollection.startAfter.

line 201 col 7: Missing concrete implementation of FirebaseQuery.startAfter.

line 292 col 23: The getter 'future' isn't defined for the class 'StorageUploadTask'.

line 54 col 18: 'enablePersistence' is deprecated and shouldn't be used.

Document public APIs. (-1 points)

70 out of 70 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Maintenance issues and suggestions

Prefer published dependencies. (-100 points)

The source code in a git repository is mutable and could disappear.

Use constrained dependencies. (-20 points)

The pubspec.yaml contains 1 dependency without version constraints. Specify version ranges for the following dependencies: firebase_auth.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and crossfire_flutter.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
cloud_firestore ^0.8.0 0.8.2+3 0.11.0+1
crossfire ^2.0.0 2.1.0
firebase_auth 0.6.2+1
firebase_core ^0.2.5 0.2.5+1 0.4.0
firebase_database ^1.0.4 1.1.0+1 3.0.0
firebase_storage ^1.0.2 1.1.0+1 3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test