Cross-platform APIs for Firebase.
see the project page for usage examples
Add this to your package's pubspec.yaml file:
dependencies: crossfire_flutter: ^3.0.0
You can install packages from the command line:
$ flutter pub get
Alternatively, your editor might support
flutter pub get.
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|3.0.0||Mar 4, 2019|
|2.1.0||Mar 12, 2019|
|2.0.0+3||Sep 25, 2018|
|2.0.0+2||Sep 13, 2018|
|2.0.0||Aug 21, 2018|
|1.0.0+1||Jul 11, 2018|
|1.0.0||Jul 11, 2018|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Jun 15, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
Detected platforms: Flutter
References Flutter, and has no conflicting libraries.
lib/crossfire_flutter.dart. (-44.03 points)
lib/crossfire_flutter.dart failed with 2 errors, 1 hint:
line 155 col 7: Missing concrete implementation of FirebaseCollection.startAfter.
line 201 col 7: Missing concrete implementation of FirebaseQuery.startAfter.
line 54 col 18: 'enablePersistence' is deprecated and shouldn't be used.
Document public APIs. (-1 points)
70 out of 70 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.
The package description is too short. (-20 points)
Add more detail to the
description field of
pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.
Maintain an example. (-10 points)
Create a short demo in the
example/ directory to show how to use this package.
Common filename patterns include
crossfire_flutter.dart. Packages with multiple examples should provide
For more information see the pub package layout conventions.
|Dart SDK||>=2.0.0 <3.0.0|