crossfire_flutter 3.0.0

crossfire_flutter #

Cross-platform APIs for Firebase.

see the project page for usage examples

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  crossfire_flutter: ^3.0.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:crossfire_flutter/crossfire_flutter.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
26
Health:
Code health derived from static analysis. [more]
55
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
20
Overall:
Weighted score of the above. [more]
34
Learn more about scoring.

We analyzed this package on Jul 22, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19
  • Flutter: 1.7.8+hotfix.3

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Fix lib/crossfire_flutter.dart. (-44.03 points)

Analysis of lib/crossfire_flutter.dart failed with 2 errors, 1 hint:

line 155 col 7: Missing concrete implementation of FirebaseCollection.startAfter.

line 201 col 7: Missing concrete implementation of FirebaseQuery.startAfter.

line 54 col 18: 'enablePersistence' is deprecated and shouldn't be used.

Document public APIs. (-1 points)

70 out of 70 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Maintenance issues and suggestions

Support latest dependencies. (-50 points)

The version constraint in pubspec.yaml does not support the latest published versions for 5 dependencies (cloud_firestore, firebase_auth, firebase_core, firebase_database, firebase_storage).

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and crossfire_flutter.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
cloud_firestore ^0.9.5+2 0.9.13+1 0.12.7+1
crossfire ^2.0.0 2.1.0
firebase_auth ^0.8.1+4 0.8.4+5 0.11.1+12
firebase_core ^0.3.0 0.3.4 0.4.0+8
firebase_database ^2.0.0 2.0.3 3.0.5
firebase_storage ^2.0.0 2.1.1+2 3.0.4
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test

Admin