cropperx 0.0.4 copy "cropperx: ^0.0.4" to clipboard
cropperx: ^0.0.4 copied to clipboard

An image cropper package made in Flutter. Can be used to crop & rotate images.

87
likes
120/ 140
pub points
93%
popularity

We analyzed this package 3 days ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

12 out of 17 API elements (70.6 %) have documentation comments.

Some symbols that are missing documentation: cropperx, cropperx.Cropper, cropperx.Cropper.Cropper, cropperx.OverlayType, cropperx.OverlayType.OverlayType.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

WARNING: The receiver can't be null, so the null-aware operator '?.' is unnecessary.

lib/cropperx.dart:95:30

   ╷
95 │       WidgetsBinding.instance?.addPostFrameCallback((_) {
   │                              ^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/cropperx.dart

WARNING: The receiver can't be null, so the null-aware operator '?.' is unnecessary.

lib/cropperx.dart:214:28

    ╷
214 │     WidgetsBinding.instance?.addPostFrameCallback((_) {
    │                            ^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/cropperx.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

87
likes
120
pub points
93%
popularity

Publisher

verified publisherspeedkodi.com

An image cropper package made in Flutter. Can be used to crop & rotate images.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on cropperx