craftsman 0.0.2
craftsman: ^0.0.2 copied to clipboard

A script builder inspired by Laravel Artisan (Loquacious tool)

2
likes
60 / 110
pub points
14 %
popularity

We analyzed this package on Apr 13, 2021, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/giusepetroso/craftsman was unreachable.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 4 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

bin/descriptor.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

bin/scaffold.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
ansicolor^1.0.51.1.12.0.1
flutterflutter0.0.00.0.0
intl^0.16.10.16.10.17.0
path^1.7.01.8.01.8.0
recase^3.0.03.0.13.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
meta-1.3.01.3.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.5` on ansicolor does not support the stable version `2.0.1`, that was published 26 days ago.

When ansicolor is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions ansicolor to update the constraint.

The constraint `^0.16.1` on intl does not support the stable version `0.17.0`.

Try running dart pub upgrade --major-versions intl to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Flutter 2.0.4, Dart 2.12.2.

2
likes
60
pub points
14%
popularity

A script builder inspired by Laravel Artisan (Loquacious tool)

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

g.petroso@gmail.com

License

MIT (LICENSE)

Dependencies

ansicolor, flutter, intl, path, recase

More

Packages that depend on craftsman