cpfcnpj 1.0.3 copy "cpfcnpj: ^1.0.3" to clipboard
cpfcnpj: ^1.0.3 copied to clipboard

An easy-to-use utility for CPF/CNPJ validation and formatting.

51
likes
30/ 160
pub points
79%
popularity

We analyzed this package 6 days ago, and awarded it 30 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

failed
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

Dependency resolution failed, unable to run dartdoc.

10/10 points: Package has an example

failed
Platform support
0 / 20trigger folding of the section

0/20 points: Platform support detection failed

Could not determine supported platforms as package resolution failed.

Run dart pub get for more information.

failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

  • Running dart pub outdated failed with the following output:
The lower bound of "sdk: '>=2.5.0 <3.0.0'" must be 2.12.0'
or higher to enable null safety.
failed
Support up-to-date dependencies
0 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Sdk constraint doesn't support current Dart version 3.4.4. Cannot run `dart pub outdated`.

pubspec.yaml:8:8

  ╷
8 │   sdk: '>=2.5.0 <3.0.0'
  │        ^^^^^^^^^^^^^^^^
  ╵

0/10 points: Package supports latest stable Dart and Flutter SDKs

Sdk constraint doesn't support current Dart version 3.4.4.

pubspec.yaml:8:8

  ╷
8 │   sdk: '>=2.5.0 <3.0.0'
  │        ^^^^^^^^^^^^^^^^
  ╵

Try widening the upper boundary of the constraint.

0/20 points: Compatible with dependency constraint lower bounds

dart pub downgrade failed with:

OUT:
Resolving dependencies...
ERR:
The lower bound of "sdk: '>=2.5.0 <3.0.0'" must be 2.12.0'
or higher to enable null safety.

The current Dart SDK (3.4.4) only supports null safety.

For details, see https://dart.dev/null-safety

Run dart pub downgrade and then dart analyze to reproduce the above problem.

You may run dart pub upgrade --tighten to update your dependency constraints, see dart.dev/go/downgrade-testing for details.

Analyzed with Pana 0.22.9, Dart 3.4.4.

Check the analysis log for details.

51
likes
30
pub points
79%
popularity

Publisher

verified publishermasterdeveloper.dev

An easy-to-use utility for CPF/CNPJ validation and formatting.

Repository (GitHub)
View/report issues

License

unknown (license)

More

Packages that depend on cpfcnpj